I'm in the US for 30 days and got a SIM card from Lycamobile. For some reason adding APNs doesn't work through the GUI (I add them but they never show up in the list, even after rebooting).

Instead I added the following lines to my /system/etc/apns-conf.xml, just before </apns>

  <!-- BEGIN Custom APNs -->                                      
  <apn carrier="Lyca US" mcc="311" mnc="960" apn="data.lycamobile.com" type="GPRS" user="lmus" pass="plus" />
  <!-- END Custom APNs -->  

Based on MCC and MNC data from Wikipedia and the information available online in general. I also enabled Data Roaming and International Roaming. I have rebooted my phone. I am on a Samsung Galaxy S3 running the latest AOKP nightly.

However, I still get an R in my signal tray and cannot connect to the internet. Please advise - any help would be appreciated even if it a nudge in a new direction.




I am not sure if adding APN from adb shell is the right solution. But if you want to try check this post.

what you basically do is change the prefered apn, or update the existing.


Turns out the changes need to go into telephony.db!

  • 3
    Great you were able to solve it, and even share the results with us! But... what changes? And how? Mind to include some more details? Thanks in advance!
    – Izzy
    Dec 15 '13 at 13:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.