On my Samsung Galaxy S4 I've accidentally accepted a privacy policy for the "Samsung Denial Log Reporting Service" in a popped notification. I've found in Google that it "Captures SE for Android denials in Enforcement mode on the device and uploads them to a Samsung Server".

Does anyone know how to disable this crap option?

  • This as you may know is part of Samsung Knox. I had this same issue and never got an answer from Samsung so I rooted the phone and installed a Knox free ROM. Obviously that isn't for everyone. Can you open the Knox app? You should be able to disable this denial report logging from the settings.
    – RossC
    Commented Dec 18, 2013 at 8:36
  • @RossC No, I don't seem to be able to open the Knox app.. I have android 4.2.2, if that matters. Commented Dec 18, 2013 at 9:21
  • Ok, shot in the dark: Log out of your Samsung account, and log back in. It should (hopefully) ask this question again, select 'do not show for 30 days' and cancel the request! Let me know if it works, I'll keep looking. I can't test it here as I have a knox free ROM!
    – RossC
    Commented Dec 18, 2013 at 10:06
  • @RossC I've tried relogging into Samsung account, no question so far. Commented Dec 18, 2013 at 11:48
  • Samsung Knox is a thorn in my side. It's negatively affecting the dev community and this kind of thing is not helping. You may be stuck with this reporting going on. The only things I can think of left are go into Settings > More > Appliction Manager and try to disable anything Knox related. I doubt this will work. You could root the phone but this WILL trip the Knox counter to 0x1 and MAY have warranty implications, install a knox free ROM. You could wait to see if logging in has affected it, reboot and see. Failing that welcome to the wonderful world of locked bootloaders and 'helpful' Knox.
    – RossC
    Commented Dec 18, 2013 at 12:01

1 Answer 1


You need to root your phone and remove or "freeze" everything related to OTA and KNOX. Once done, you can remove the all AVC audit file(s) in the directory: /data/misc/audit/. You may also need to put SEAndroid into Permissive mode with: su 0 setenforce 0, but this only lasts until next reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .