0

I need to setup a 802.1x EAP Wi-Fi network on a JellyBean device (Motorola Moto G).

The network is managed by the university, and they are using eduroam.

In the university configuration guide they show how to setup a TTLS-PAP connection. The problem is, in my device, the only options available in the phase 2 authentication spinner are None, MSCHAPV2 and GTC.

The configuration guide shows screenshots for gingerbread devices where PAP is also available. I've been googling a bit and seems that some ICS devices also have it available.

Could this be a problem of this particular device? Or could it be a problem of all JellyBean devices? Is this option available in KitKat?

Thanks in advance.


UPDATE
I've checked this option is shown in an old gingerbread phone. Also being shown in a 4.1 tablet.

0

Ok buddy, this method works for me:

*I have found a way to make it connect - at least it worked for me! You have to select the network from the list but while it's trying to connect, you have to long press on the network and select modify to bring up the settings window. Then just enter your settings as normal.

I only had to do this once to set up the network and now it connects automatically.*

The autor is flarge in XDA forums, i don´t linked, i don´t know if here i can do it.

CYA!

  • Yes, please do link to the source. We want answers to be self-contained, but we also want to give credit where credit is due. – ale Jan 9 '14 at 13:33
0

At least in this device, the network configuration dialog is plagued with bugs.

What I did is to create the network, save it, then long click to modify it and the options appear. I've also used WiFi Manager to configure the network. Good to know someone developed an app to do what Google couldn't get right.

And I've seen some other bugs in this dialog too. For instance, when you type the CA certificate name, then you save the network, and then you open it again to modify, the cert name is no longer there (this field used to be a spinner in previous versions, but now it is a regular text field).

A similar problem happens with the password. After typing it and saving the network, then opening the network again to modify it, the password field only contains a single character.

And it somehow seems to save the configuration mostly Ok, it is just the dialog is not initialized correctly with the previously saved fields.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.