0

Two days ago, AT&T surprised me with three bandwidth warnings within a few seconds. In quick succession, our wireless account (i) exceeded 2/3 of the 300 MB limit, (ii) exceeded 90% of the 300 MB limit, and (iii) exceeded the limit, resulting in an excess bandwidth surcharge.

I isolated the culprit to one of our S3 minis. According to the onboard usage log, Google+ had unexpectedly burned 200 MB in background transfers. I guess that this was a transfer of a 200 MB video, because that S3 had just taken one.

Google+ came from AT&T preinstalled and preconfigured to automatically back up videos, but only when there is a WiFi connection available. I think this means a transfer should never have occurred over 4G.

I have found numerous forum threads – such as "Suddenly high data usage (Google+?)" over at AndroidCentral.com – in which identical experiences were reported, both in 2012 and 2013. Some of these threads implicate another app called Gallery, which also comes preinstalled and which I do not use and know nothing about. For more examples, Google [ android google+ sudden data usage ].

Is there a long-standing bug in Google+? How can I correct it going forward? Can I force Google+ to honor the WiFi-only setting? Do I need to change a setting in Gallery?

Can I expect to recover the surcharge from AT&T, considering that they were the ones to preinstall and preconfigure the software so that this could happen?

  • I've not encountered this bug, and I'm a pretty heavy G+ user. As for whether you can get the money back from AT&T, that's beyond the scope of this site. – ale Dec 18 '13 at 1:46
  • If you have your WiFi set to 'switch networks' (default setting in 4.3+) then it will jump to 4g if it thinks your connection is unstable. I find it constantly tells me the WiFi is unstable on the Galaxy S4, it seems very delicate in Samsung devices. This is a solid WiFi connection I'm using about 2 feet from the router! Pop into your WiFi advanced settings. – RossC Dec 18 '13 at 10:37
  • @RossC On this device, Android 4.2.2, I see a setting "Check for Internet service: Auto switch between Wi-Fi networks and mobile networks". It's turned off. – MetaEd Dec 18 '13 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.