0

I am compiling the AOSP rom for Nexus 7 flo. After the build is completed, I always end up at this screen "type password to decrypt storage".

The factory images work correctly, and the device works. Also there has never been any password. I could understand that the problem seemed to be with userdata partition, so I flashed everything from the factory images, and then flashed only my own compiled userdata.img. And it works, so I am left clueless as to where the problem could be?

Any ideas?

Edit1:

So after some searching/asking around, it seems this problem can occur if partitions overwrite each other (any of the img files is too big, particularly boot.img). But how can I verify this? Any thoughts on this?

0

Are you using make -j# otapackage? If so it should result in a ZIP that should flash with no problems. Also fastboot format all partitions to get rid of the decrypt error. If the source is untouched, i.e. the ROM compiled is the same as the stock ROM, the images should flash without any such error.

| improve this answer | |
  • I wasn't using otapackage. – Niket Kandya Dec 18 '13 at 21:37
0

OK, I kind of fixed it/ worked around it.

The issue was with the fstab file. In case of 4.3 and later it is fstab.device in device/vendor/product. This has by default how the partitions need to be mounted when the system boots up which by the way is mentioned in init.rc included in the same directory and gets packed into ramdisk.img. In my case, this file had a "encrypatable:some path" for userdata partition. I removed that parameter, and it worked. Interesting to see that the stock ramdisk also uses the same parameter and works. Guess, it needs more looking into, but works for me now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.