1

I just wiped my data and dalvic cache and formatted /cache, /system and /data. I put philz touch recovery (an enhanced CWM) on my phone and now wanted to install a rom. But when I install OmniROM it always tells me failed to verify whole-file signaure, and when I want to use CyanogenMod it tells me error in tmp/update.zip status 7.

The problem now, is that I now have no ROM on my phone and only can be in recovery mode. But, when I use adb sideload filename in the console I only get error: closed also my Windows doesn't show my phone so I can't put another ROM on it to test it.

What could I do ? I have no system on my phone at the moment and can only go into recovery mode.

  • Do you have a custom recovery installed? You should be able to mount your SD card through the recovery. Alternatively can you get an SD card adapter for your computer and copy another ROM on to it? Have you verified the MD5 sum of the zip file? Is it for your exact device model? – RossC Dec 18 '13 at 8:15
  • 1
    Took me a little to see the device. Searching for N700 didn't convince me #D So full ack to RossC's comment. I take it "philz touch recovery" is a custom recovery (never heard of it, though); so the culprit could be you've picked an incompatible ROM, or your download was incomplete. Have you tried opening the update.zip on your computer to check whether it's broken? // also please check the links I've added, if they're correct :) – Izzy Dec 18 '13 at 8:26
  • Hi. Look at my answer. I solved the issue and also answered to your comments. Thanks for your support – Musterknabe Dec 18 '13 at 8:34
1

I fixed it! I did it like this: The problem .. ? I don't know it.

In console these commands helped me

adb start-server // start the adb
adb usb          // restart the mobile phone with usb mode
adb sideload philzrecovery.zip // 
adb reboot recovery
adb sideload custom rom
adb sideload google apps

Answering both comments of RossC and Izzy

I didn't have a custom recovery installed. philz touch recovery is a custom recovery that is based on cwm and has a touch interface. U can see it here

MD5 sum was okay and was the same as from the downloaded page. So that would mean there were no corrupt files or downloads. Gladly that it worked. Just seems like you can't flash custom roms with a stock recovery (I don't know if it's true, but seems like it).

So the steps are ( for windows )

  1. Install adb driver ( I used these )
  2. Navigate to the installation foldler with CMD (next steps are cmd commands)
  3. adb start-server
  4. adb usb
  5. adb start-server
  6. In mobile phone "Install zip from ADB"
  7. adb sideload (PhilZ Recovery)
  8. adb reboot recovery
  9. adb start-server
  10. In mobile phone "Install zip from ADB"
  11. adb sideload (Custom ROM)
  12. adb reboot

Done!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.