I'm trying to get started with development. I have just installed the SDK (ADT v22.3.0-887826) on Linux Mint 15 x86-64. I haven't made any configuration changes to the default installation of ADT, and I don't think there's anything unusual about my system configuration. Eclipse seems to be working fine.

I created a virtual device with default settings (Nexus 4, Android 4.4 image). It takes about 4 minutes to boot, then the home screen comes up. I can navigate the home screen and settings menus, and it's a bit sluggish but it works. When I attempt to launch the stock browser, the screen goes white for a few seconds, then black for about 45 seconds, then it says "Unfortunately, Browser has stopped." I tried again with a QVGA 240x320 device and get the same results. I have tried different settings for GPU acceleration, RAM and VM Heap. I have rebooted my system and tried again with no other programs running. Nothing has helped. I've got a Core 2 Duo E4500 @ 2.2GHz, with 3GB RAM, which I would think is sufficient, but I haven't found any minimum hardware requirements.

I checked the system requirements on the ADT Bundle download page, and I noticed that I have OpenJDK-7 installed, not JDK-6. Could that be the problem? Is it not backward compatible?

Is there an error console or some other way to get more information to diagnose problems? This generic error message is pretty useless.

UPDATE:

Thanks for the tip on logcat. There were LOTS of errors, warnings and failures in there. So I went ahead and installed Oracle JDK-7 (it is compatible) even though there have been reports of successfully using OpenJDK. I also reinstalled ADT. But I'm still getting the same issue, "Unfortunately, Browser has stopped." I can launch other apps, like Calendar, Calculator, Contacts, Messaging, etc.

...Solved it. See answer below.

  • My previous comment indicted OpenJDK, but now that I re-read your question, I see you're not actually trying to build an app yet. In which case, the JDK should have nothing to do with your emulator or anything running in it at this point. – dotVezz Dec 18 '13 at 21:18
up vote 6 down vote accepted

Digging through the logcat, immediately after the com.android.browser activity is launched, I found a "Fatal signal 11 (SIGSEGV)" in vold, the volume daemon that handles storage. Lots of other storage related issues in the log too. So I checked the virtual device settings one more time and noticed that the SD Card size was not specified. I had assumed that the default settings should work, but apparently not. I entered 2 GB for the SD Card, restarted the emulator, and the browser works fine now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.