I had my Alpine radio paired and working with my nexus 5. Then someone unpaired the device on my phone when they wanted to pair it to a different bluetooth device. Apparently the Alpine phone passphrase is '0000' (if it is needed - I can't recall it being asked for when I initially paired it and it seems that that is a "default" PIN that is attempted automatically?)

The new device did need a passphrase which was '1234'

I have been trying (unsuccessfully) to re-pair my car stereo with the phone. The message I get is that pairing was unsuccessful due to an incorrect PIN/passphrase.

I can't find anywhere in setting on how to change the passphrase - because it never asks me for one.

I am assuming somehow this is a bug and the last successful PIN is being used.

Previously my stereo would prompt if it should allow the pairing and i would select Yes - this time it doesn't work.

I have seen what looks like similar questions/issues on other forums. It seems to be a bug or at best a horrible hidden configuration somewhere.

To reiterate:

  • device A was previously paired fine.
  • device A was unpaired
  • new pairing to device B with a PIN
  • no longer able to pair with device A - with an error message of bad PIN/passhphrase but I never supplied one for this device.

Any pointers or URLs or suggestions would be most appreciated. (aside from resetting to factory)

EDIT: To answer the questions in a comment:

  1. I have to look up the model number
  2. I cannot attempt to pair using PIN 0000 - the phone does not give me a choice to do so. I wish it would - in that case I could probably do it.
  3. Same as above
  4. I have turned off the radio - not sure how to disable BT on it - I will try that
  5. Yes - many, many times - as well as shutting down phone
  6. I am pretty sure visibility is on. It was working fine until then and I will try it with another phone later today - it is visible. The phone discovers it. Must be on
  7. The message is displayed on the phone.
  • 1
    I have some questions about yours: 1. What model is your Alpine car stereo? 2. Have you tried to pair your Nexus 5 using '0000' as PIN code? 3. Using '1234'? 4. Have you disabled and enabled bluetooth in your car stereo? 5. In your Nexus 5? 6. How is set the Visibility Mode of car stereo: ON or OFF? 7. The error message comes from your phone or from your car stereo? Dec 25, 2013 at 10:26

2 Answers 2


The issue was not Android. (Except perhaps the misleading error message.)

The problem, it turns out, was that the pairings on the radio were "full". It seems this radio (CDE-133BT) allows 3 pairings. Well, I inadvertently renamed my Nexus some point along the way when I also unpaired it from the phone. Attempting to re-pair without first emptying a free slot on the radio failed. I do not know what the comms is like for denying a connection based on that, but either the radio sent incorrect information about why the pairing was denied or Android reported an incorrect reason.

The problem is solved - By the way - the way to empty the bluetooth pairings is NOT in the manual - I watched a YouTube video of someone making pairings and discovered a way to find what the pairings were.

Not sure if this Q/A still belongs here, but maybe it will be helpful for someone with an Alpine CDE-133BT someday.

  • Tim: We are glad to know that you managed to solve the problem and yes, this Q&A belongs here because that's the idea: to help anybody having the same or similar problem. BTW, if you could add the link for that video you watched, that would be good. Dec 27, 2013 at 3:55

It seems there is no way to change your default PIN code, because I've found the following note on some manuals for Alpine car stereos in the sections about Bluetooth pairing (emphasis mine):

The PIN code is fixed as "0000".

(Note found in Owner's Manual for Alpine CDE-HD137BT, Alpine CDE-133BT, Alpine CDE-143BT, Alpine CDE-147BT... I don't know what model you own)

I can't test the following because I have neither a Nexus 5 nor a Bluetooth capable car stereo (in fact I have no car, sorry), but it might help you to solve your problem (the names of settings might be different in Nexus 5 than in my Galaxy Nexus):

  1. In your Nexus 5 go to your app drawer, tap Settings.
  2. Tap Bluetooth (not the ON/OFF switch).
  3. Enable Bluetooth (using the ON/OFF switch). Wait until list of paired devices is loaded.
  4. If in the list of Paired devices it is included your Alpine car stereo, long tap its entry.
  5. From the menu for that entry select Unpair.
  6. Tap Search for devices.
  7. Your car stereo should be detected again and be added to Available devices list: Proceed with the pairing procedure as you normally do, hopefully this time it will allow you to input the right PIN code.
  • thanks! But, the problem is that it is NOT paired. The problem is the phone does NOT allow me to enter a PIN at all. The devices are UNPAIRED. The radio is discovered. Attempting to pair them fails.
    – Tim
    Dec 26, 2013 at 4:46
  • Different manufacturers will use different Bluetooth stacks and each is implemented differently. There is no mandate that manufacturers must implemented Bluetooth stacks equally according to the standard set forth here. So, if Bluetooth devices won't pair properly, then it is safe to assume that the Bluetooth stacks are implemented differently and are not compatible wrt to functionality, like entering a password. You could try to reset the Alpine unit and try again, but I wouldn't hold my breadth...
    – ChuongPham
    Dec 26, 2013 at 9:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .