4

I'm using Android 4.4.2 with my new Google Nexus 5. I have a question about adding new contacts. On my workstation I'm running my own cloud system. It is an Apache sever running eGroupware on it and I'm using Sogo-Connector and Synthesis Sync Clients to synchronize all my clients. I synchronize all my contacts and calendar data over my different clients such as Laptops and Mobile phones. Now I want also use the cloud to sync my Google Nexus. Adding a new contact on the workstation (or any other client except the Nexus 5) works fine and after synchronization the new contact is available on the Nexus 5.

If I want to add a new contact on the Nexus 5 itself, I really want to force the Nexus to add it in the internal phone addressbook instead of the Google Account. However this option is not available, because the phone forces me to sync it with the google account.

How can I add a new contact to the internal phone addressbook?

2

You could try to disable Google People (Contacts) Sync application using Storage/Apps menu item and then disable Contacts sync option for Google account. After that you should be able to add contact which is marked as phone only - not synced.

Hope this helps...

  • Thanks for your suggestion. How do I disable the Google People Sync app? – user8 Dec 25 '13 at 11:46
  • Settings/Storage/Apps long press and details should open. There should be "disable" button in upper right corner. – neHus Dec 25 '13 at 13:14
  • You could also try to import the contact using .vcf file. It will bypass that "sync with google account" dialog... – neHus Dec 25 '13 at 13:20
  • Thanks for your patience, but in Android 4.4.2 there is nothing like /Storage/Apps. I can't find anything like this in the setting to disable the contact ab – user8 Dec 25 '13 at 13:29
  • 2
    Please go to "Settings" application then find item "Storage". Under Storage there is item "Apps" or "Application", long press -> list of application should open. Find that "sync" application. Open details for it and disable... – neHus Dec 25 '13 at 13:33
2

I do not know Sogo-Connector and Synthesis Sync Clients, but I am sure it's possible to select an account for synchronization. Look for MyLocalAccount in Google Play Store. This allows to create a local account. Once the app is installed nothing happened. Even you will not find this app in your list. But now you are able to create an account which is a local one. You have to go to System settings -> Accounts and create a new one. Now you see a new account and you are also able to add contacts to this account. Of course you have to configure your connector to add this account for sync operation.

I am using MyPhoneExplorer to sync (in combination with MyLocalAccount) all these things with success since almost 3 years. Generally it does almost all I want to do. I can sync from different PC's (home and office). What I cannot do is to sync to different devices, for example to phone and to tablet with the same database on the PC. Do you know, is this possible with your solution?

0

You can't do it with the same Google Account that is made to sync with other clients.

Only alternative is use a separate Google A/C imo.

  • thanks for your quick answer. Just a small question: The only reason I set up a Google account was to use the playstore. So removing the google account is not an acceptable choice, since otherwise I can't download any apps. What do you mean by a separate google account? I do not sync any data with this google account. All sync options are set to off – user8 Dec 23 '13 at 11:47
  • I'm not really sure what this answer is saying. The first part makes sense (Can't store internally if there's an account available to save to) but what's the second part saying? – dotVezz Dec 23 '13 at 13:19
  • @dotVezz Do you know if it is possible to somehow add a new contact into the internal phone addressbook while having (but not syncing) a google account. I really just need the google account for the playstore. In the menu settings for the google account all sync are set to off. – user8 Dec 23 '13 at 13:46
  • @user8 I wish I knew. Seeing your question made me open up my own Contacts app and I was pretty surprised that it forces it to go to one of my Google Accounts. I can't find any option to make it save to anything else. – dotVezz Dec 23 '13 at 13:47
  • @dotVezz A workaround is to add new contacts just on my laptops / workstation or the webapplication of eGroupware itself and then sync it to the Nexus 5. But this is not satisfactory at all! – user8 Dec 23 '13 at 13:49
0

A work around is to go via the phone dialler icon, click the three pips on the bottom right for options and select new contact.

This will allow you to create a local contact, but no need to add the number here, just add the name.

once your done, go back to your message, click the options button and select 'add people'. it will allow you to add the number to an existing contact, so pick the contact you created a moment ago, selecting the device type. hope this helps.

0
  • Go to Settings→Storage→Apps
  • Scroll to Google Contacts Sync
  • open this app
  • select disable

You can now add contacts without the pop up saying it will sync with Google. It will say Phone-only unsynced contact. Also when disabling Google Contacts Sync, a warning will say "may affect other apps"; click ok anyway. When done adding contacts go back to Storage→Apps, select disabled (top right): Google Contacts Sync will be there re-enabled, and your good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.