0

I used to plug it in, and it would show up and I could download the pictures and movies and such. Today, it will not mount. It is charging from the computer, but I can not download any of the stuff I've done.

Running windows 7 on my computer.

I've turned it off and on again, it is not working.

I probably have added an app or two, I am not sure. It has been a while since I uploaded from this phone, but I plug it into the computer every night. Is it possible I accidentally hit a tick box and instructed it not to mount?

  • 1
    Welcome to the Android Enthusiasts, Daniel! We will need a few more details in order to be able to help you: Anything changed since it worked last time (settings, new apps)? And the old IT question: "Have you turned it off and on again?" Sometimes things get stuck, so a reboot might help. – Izzy Dec 24 '13 at 5:51
  • Also: have you tried connecting your Galaxy Note 3 to another computer, if any? Have you tried with a different (but compatible, of course) USB cable, if any? – Francisco Alvarado Dec 24 '13 at 5:55
  • You probably don't have the correct Samsung USB drivers for Windows 7. Download the USB drivers, install it, plug in your Samsung Galaxy Note 3 and let Windows install the appropriate drivers to allow your device to connect seamlessly with Windows. – ChuongPham Dec 26 '13 at 11:10
1

What operating system do you run on your computer? That sometimes happened to me when I used Windows. Have you tried using AirDroid, though? I use that now. It basically does remotely, what you would do with a USB.

But that's just an alternative, I'll wait for your response to see if maybe I have a solution.

  • Indeed, this is a good emergency solution if what you need is to transfer files between your computer and your device with some urgency. – Francisco Alvarado Dec 24 '13 at 5:58
  • Yes, it is, haha. Is this not what you were trying to do, though? Because you have cross-file browsing and sending SMS, accessing camera, Gallery and more. But have you tried another cable? Or maybe mount settings in Android? – Mike Wentworth Dec 24 '13 at 6:01
  • I know the requirements, but you don't need the same network now, only "any" type of network connection. But that just uses up more carrier data. – Mike Wentworth Dec 24 '13 at 6:11
  • Well this isn't an FAQ per say, but try: airdroid.com/download I'm trying to find the FAQ as well. – Mike Wentworth Dec 24 '13 at 6:17
  • Computer requirements: There is no need to install any software or drivers on your PC/Mac though - an existing web browser (Google Chrome, Firefox, Safari) is enough. Source: Install AirDroid. (This info is from Oct 15, 2013) – Francisco Alvarado Dec 24 '13 at 6:21
0

I solved similar problems by installing Samsung Kies on my Laptop (Windows 7). It installed all drivers that couldn't be found using Windows Update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.