3

I have the HUAWEI G520-5000 mobile phone which was bought in April 2013 from China during a business trip. The device, despite of being locked for China Mobile carrier, is working properly for my carrier (Cosmote) in Greece. I don't have problems with talking or accessing the internet. My problem is that my Google account does not recognize my device and I can not use the Google Play store and it is impossible to install even the simpliest application. I suppose that the problem is the Android OS on my device which seems to be modified by China Mobile and Huawei (only Chinese apps are accepted by the device and the s/n of the OS is also pretty strange (something like 123456ABCD). I would appreciate if somebody could help me out with my problem. Thanks

  • 1
    Google play services are blocked in China, you may have to root to lift the regional restrictions in the firmware. Check out the how to root my device thread: android.stackexchange.com/questions/1184/… – RossC Dec 24 '13 at 11:17
  • No, rooting will not help. The OP will need to wipe the firmware and install another into the device. This is because pretty much all mobile devices made for China market primarily work with Chinese apps - thus, instead of Google Play, they get their equivalent Chinese market app. They are a paranoid bunch over there! – ChuongPham Dec 26 '13 at 10:44
  • Is there a some way to find new firmware and fix my problem by myself or should I find someone to have this job done? Are there any risks for my smartphone? – Andreas B. Dec 27 '13 at 16:55
  • Is the Google Play Store app available on that device? Can you create a Google account on it, or are the appropriate settings missing as well? – Izzy Dec 29 '13 at 21:27
  • No. Unfortunately the Google play store is not available on my device and this is the main problem I have. – Andreas B. Dec 30 '13 at 1:39
-1

The following worked for me, but requires root:

  1. install Total Commander
  2. open it
  3. browse to /system/etc
  4. look for a file named hosts
  5. long-press the file, then chose to edit it via the CMD editor
  6. comment out the second line (place a # in front of the digit)
  7. save the file (approve superuser request for Total Commander when asked for)

Now the problem should be solved!

| improve this answer | |
  • 1
    you've just damaged all our ears! Please, do not use ALL CAPS – that's considered screaming and impolite. Apart from that, it makes your post harder to read. – Izzy Oct 27 '14 at 12:42
  • Besides bad formatting, this is a wrong answer. – iBug Jul 23 '17 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.