1

I'm having a strange problem with my Samsung S4 using the stock, current firmware. The phone is new and straight out of the box. Updates have been allowed to proceed and now report current.

Google+ reports 'Data connection error'. This error should not be taken literally as there is very clearly a fast network connection available: on both 4G and wifi. Every other network accessing app, including other Google apps (including those using the Google user account) work fine.

I've cleared the app cache and data without effect. The issue existed prior to and after a Google+ app update.

Any suggestions?

  • Google+ comes bundled with the firmware installed on your S4. Just uninstall the latest update via Application Manager to take you back to the Google+ version that comes with the phone. If you still get the same error, log a bug report with Google and get them to fix their crappy product. – ChuongPham Dec 26 '13 at 10:28
  • As I stated above, the issue exists both before and after the Google+ app update: perhaps I didn't make it clear enough that the initial version (prior to update) in the version locked in firmware. What is the point of emailing Google, I might as well shout at the wall. – user3132567 Dec 26 '13 at 12:04
  • Well, a friend of mine has Google+ v4.2.4 on his S4 international version and it seems to run fine before and after the update. What version do you have on your device? – ChuongPham Dec 26 '13 at 14:53
  • It is unfortunate that this question stayed without reply. It seems I have the same issue but with my S3. The phone works perfect with all apps on Wifi and 3G/LTE. However, for the last 2-3 weeks, Google+ just stopped being able to update. I tried to clean data and cache without success, then I cleaned data and cache and uninstalled the app to go back to the firmware version of Google+, same issue. I then re-cleaned data and cache and re-updated to the latest version, Google+ is still not able to connect. – jmbouffard Apr 14 '15 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.