I just got an Android tablet and when I try to install an app on the Play store it says:

error retrieving information from server [RPC:S-3].

I've tried clearing the data for the Play Store app & turning it off & back on but it didn't work.

  1. Try going Settings>Accounts>Google>Tap your account> tap three dots in the upper right (or press menu button) "Remove Account".
  2. Go to "Settings"->“Applications”->“Manage Applications”
  3. Select "All"
  4. Scroll to and tap “Google Play Store”
  5. Tap “Force Stop”, tap “OK”, tap “Clear data”, and tap "OK".
  6. Tap the Back button to get back to the applications list.
  7. Scroll to and tap “Google Service Framework” (or Google Play Services)
  8. Tap “Force Stop”, tap “OK”, tap “Clear data”, and tap "OK".

Now reboot (switch on & off) your device.

  • 1
    Try going Settings>Accounts>Google> Tap your account> Three dots in the upper right (or press menu button) "Remove Account" ... then read your account .. then if you want, clear Play store cache and data and try it. Worked for me! – OpenAndroid Dec 27 '13 at 11:34
  • +1, why don't they just invent a button that recomputes all caches. hilarious. – Jens Gustedt Sep 11 '14 at 17:26

protected by Community Dec 28 '13 at 10:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.