5

When I plug my HTC ONE into my computer via a USB cable, it always wants to try and install a bunch of random things on my computer that I really don't want nor need. Just plugging it in with the current drivers installed, it shows up fine in my Portable Devices list on Windows 7, as seen here:

Portable Devices

Even with it working perfectly fine already, it still insists on installing other stuff. It wouldn't let me capture a screenshot of the User Account Control dialog:

Do you want to allow the following program to make
changes to this computer?

Program name: TL-Boots Application
Verified published: HTC Corp.
File origin: CD/DVD drive

Is there any way I can configure either my phone or computer to stop trying to install all this crap ever time I plug my phone into the computer? It's really annoying always having to click No on that popup every time I plug it in. I really don't want all their excess software that I'll never use on my computer. I can't seem to find anything in the USB settings that mentions auto-installation. Last time I installed this junk it made my simple storage access through My Computer stop working (my phone stopped showing up in the list when connected). That's literally the only feature I even use, so that was rather inconvenient.

4

Don't have a windows machine handy but look in the microsoft site advises, (for windows 7):

AutoPlay lets you choose which program to use for different kinds of digital media, such as music CDs or pictures from your digital camera.

Show all To turn AutoPlay on or off

When you turn AutoPlay on, you can choose what should happen when you insert different types of digital media into your computer. For example, you can choose which digital media player is used to play CDs. When AutoPlay is turned off, you are prompted to choose what you want to do when you insert digital media into your computer.

Open AutoPlay by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type autoplay, and then click AutoPlay.

Do one of the following:

To turn AutoPlay on, select the Use AutoPlay for all media and devices check box.

To turn AutoPlay off, clear the Use AutoPlay for all media and devices check box.

Click Save.

N.B. It is almost always a good idea to turn this off as it stops malicious code on CDs/DVDs/USB keys/etc from being able to run.

  • This answer is excellent in my opinion. But one thing I'm not clear on: "N.B."? (Although the point made in that line is also 100% correct) – dotVezz Dec 30 '13 at 18:10
  • 2
    @dotVezz It's Latin - "nota bene" or "note well" - to emphasize an important note. -- Steve: I didn't turn off all AutoPlay stuff because there are things I like to automatically run. It does allow you to go into AutoPlay settings and choose which types of media you want to auto-run, and I just turned off Software and Programs and left everything else alone, which seems to have worked. – animuson Dec 30 '13 at 19:18
  • You can also disable only In the Autoplay menu, you'll see (probably near the bottom) a line corresponding – Itamar Jan 2 '14 at 7:20
0

Adding on @steve's answer: You can also disable only the Autoplay action for your HTC.

  1. You can access the Autoplay menu directly from the start menu by writing Autoplay in the search box.
  2. In the Autoplay menu, you'll see (probably near the bottom) a line corresponding to your HTC, where you can choose no action
  • The problem with this is that, at least with my phone, the software it's trying to install is not being recognized as being from my phone. Enabling/disabling Autoplay for my device name only allows me to automatically open the folder or sync files through Windows Media Player. The actual software installation is being inputted as a "CD/DVD drive" as described in the message in my question. That's why I was forced to disable the "Software and Programs" Autoplay option instead. – animuson Jan 2 '14 at 7:27
  • There are several options for CD or DVD under Media. You can try checking which one of these will block this specific autoplay. The most efficient way (log2 of N) would be to block half of them and see if that works, see which half is relevant and block half of that half, etc. – Itamar Jan 2 '14 at 8:20
-2

Try to connect the phone as MTP Device > Under the USB connection settings.

Should help!

  • The device always connects as MTP, it's not an option to turn it on or off. – animuson Dec 27 '13 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.