I am running Cyanogenmod 10.1.3 on my Samsung Galaxy SII (GT-I9100), and starting yesterday my keyboard continuously crashes with the following message:

Unfortunately, Android keyboard (AOSP) has stopped.

This message pops up very 10 seconds or so even when I am not trying to type. I thought it might have something to do with my recent install of the DU Speed Booster app. But after uninstalling it I still get the same problem.

This is very serious, as my phone is rendered almost completely unusable since I can't enter any text, and message keeps popping up preventing me from even doing things that only require touch.

Any help would be appreciated!!


Here's a few tips for troubleshooting:

Go to System Settings > Apps > click Android keyboard (AOSP). Clear Data. Clear Cache.

If that doesn't work, and you have a custom recovery, reboot into recovery and clear the entire cache, clear davlik cache, and go to advanced > Fix permissions.

Other than that, you could try uninstalling and reinstalling from Google Play or downloading a different keyboard.

  • I tried all that and still get the error messages, so I ended up installing another keyboard from the Google Play store and deactivating the Android keyboard. Now things are working fine, thank you! – hpy Dec 27 '13 at 12:24
  • 1
    Glad a new keyboard worked for you. If you want the AOSP keyboard, I would still try reinstalling from Google Play, or even re-flashing GApps. Else, I highly recommend SwiftKey as an alternative. – sweeds Dec 27 '13 at 13:51

I noticed that the problem is with the word completion feature. Just set it to hide all suggestions and it will stop annoying you. The option to hide is available in the android keyboard configuration.


I downloaded a different keyboard then disabled the aosp keyboard in settings>apps>all apps>android keyboard aosp>disable. If your really screwed like I was you'll have to scrole through the top apps in the market until you find a keyboard to download since you can't search anything.

  • 1
    That's already part of this answer. As for the "screwed" part: you can always search the play store from your computer, and trigger the install from there. – Izzy Jun 23 '14 at 7:35

Clear data & cache in Android Keyboard & Dictionary Provider in Settings > Apps > All ... if problem still persist, try reboot into recovery & wipe cache partition format dalvik cache. i had to do it several times and tried clearing cache of keyboard-related apps such as User Defined Dictionary and Pico TTS. good luck!


Solution: install proper version of "Google Aplication". CM 10.1.3 needs GApps 20130812. Read: http://wiki.cyanogenmod.org/w/Gapps for more info.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.