I have a prepaid T-Mobile line that I use for development purposes only. I do not really use it for calls. However, some 800-number company has been calling me constantly (which I have already added to a "block" contact which directs all calls to voicemail via Contact app menu option). However, they leave voice mails which creates this notification on my phone:

voicemail notification

Click the image for larger variance

But I cannot swipe away this notification. It is a constant and persistent notification.

Is there a way I can either:

  1. Never show voicemail notifications (without having to call T-Mobile and disable my voicemail box)
  2. Swipe to remove the notification or hide the notification (via an app or similar?)

I am rooted on a stock Nexus 5.

I would have just used Google Voice as my voice mail box but apparently T-Mobile prepaid lines cannot have call forwarding so I can not use that option.

  • I'd say this is a bug in Android. Or the operating system is being abused by the carrier. A notification you can't dismiss is malware. – PJ Brunet Sep 19 '15 at 2:53
up vote 3 down vote accepted

You can install and configure T-Mobile's own Visual Voicemail app. You will get notified about your voicemails through it instead of the system's Phone/Dialer app, with the ability to dismiss that notification. As a bonus, you can also listen to and delete your voicemails without having to dial in and waste prepaid minutes.

Be aware that this app needs to be able to send and receive one SMS message in order to enable its functionality. If you are using Voice+ feature of CyanogenMod custom ROM, you will need to temporarily disable it.

  • Hm, I didn't think about trying T-Mobile's Visual Voicemail. However.... when I try to install it (via web), it says that "No eligible devices for app install." Does the app require it to be a T-Mobile branded device? I'm using an unlocked Nexus 5. I also can't find it searching the Play Store on the device. – Bryan Denny Dec 30 '13 at 19:57
  • I had problems finding it on the Play Store as well, I had to go to My Apps because I remembered having installed it in the past. I am running it on an unbranded Galaxy S4 Google Play edition, so that can't be the reason (it also shows as installable on my Galaxy Nexus and AT&T's Galaxy S2.) – Chahk Dec 30 '13 at 20:15
  • According to a not very helpful post by T-Mobile CSR, it could be because it's not compatible with KitKat yet. – Chahk Dec 30 '13 at 20:19
  • 2
    @BryanDenny: FWIW, I've been using T-Mobile's VVM app on my N5 without any issues. I just had to sideload it, since like you said, you can't install it via the Play Store. I got an apk from this XDA thread. – eldarerathis Jan 25 '14 at 5:37
  • @eldarerathis thank you for sharing that! Just installed it and it works perfectly! I think this will be the solution to my problem, I'll try it out for a few days. Thank you!!! – Bryan Denny Jan 25 '14 at 12:36

The only thing that worked for me is to stop the Phone Application. It restarts itself again, so you don't have to worry for missing calls or anything.

Steps:

  1. Settings -> Apps -> ALL -> Phone.
  2. Click Force stop

Source: Clear Voice Mail Notification Icon

  • I used "clear data" instead of "force stop" and the icon vanished. It was a few minutes ago, so I still don't know if it'll come back when I restart or by its own will. Device is a Galaxy S4. – Carcamano Aug 25 '15 at 14:30
  • Clear data didn't work for me. Moto E2. Neither did force stop, though... – Cullub Mar 31 '16 at 17:43

I am in the same boat as you. Since I found no way to actually disable voicemail notifications on my Nexus 5, I instead configured the longest possible voicemail greeting the T-Mobile system would allow, which consists of complete silence for 3 minutes. I have not gotten a single voicemail notification since.

  • 1
    Funny stuff :) I'd upvote if this was comedy.stackexchange.com ;) – Chahk Jan 25 '14 at 14:30

I think aside from calling your carrier, there are only so many [few] things you can do.

I've been reading, and it seems like you can change your Voicemail number in settings so call forwarding would be an option.

http://forums.androidcentral.com/samsung-galaxy-s4/276901-there-way-turn-off-voicemail-notifications.html

And a very helpful YouTube video

http://www.youtube.com/watch?v=_eXN-8wxtk8

From the video: force stopping the Phone application will clear all notifications from the Phone application, including the voicemail notification.

  • 2
    Unfortunately, I cannot use call forwarding as an option as T-Mobile doesn't allow it with prepaid accounts. Otherwise I would just forward it to my Google Voice mailbox and let the spam voicemail die there. – Bryan Denny Dec 30 '13 at 15:30
  • Can you contact your carrier, then? You can tell them to disable your Voicemail Feature. Or you can go to your T-Mobile app and they may have the option there. Did the YouTube video not help, though? – Mike Wentworth Dec 30 '13 at 18:33
  • Yes but wanted to contact T-Mobile as a last resort as I'd rather not waste time on the phone with their customer support. Force stopping the phone application does work (via video), but I'm called 5+ times a day with a voicemail left every time so it isn't a very feasible solution. There is no option in the T-Mobile app. Only to change password or to turn password on/off. – Bryan Denny Dec 30 '13 at 19:11
  • 1
    Also, please try to give some information when you post a video. You could have easily wrote to force stop the Phone application, no need to watch a minute video. – Bryan Denny Dec 30 '13 at 19:12
  • True, you're right; but then I don't think there's a way, sorry Bryan. I hope I'm wrong for your sake, because I know how annoying it can be. But as of now, don't think there's a way out. Perhaps look on Google Pla for a call blocker that WON'T send the call to Voicemail? I remember a while back they had something like that, but I never had use for it. Your query "Voicemail Block" or "Call Blocker" but look for the Voicemail blocker as your key feature. – Mike Wentworth Dec 30 '13 at 20:15

I had a similar issue, but it was with visual voicemail notifications.

Easy fix for this instead of calling T-Mobile is to:

  1. Login to your T-mobile account > plans > services
  2. Unselect the free visual voice mail service
  3. Go into your phone and go into apps > running apps and disable all the T-Mobile services (apps labeled in pink)

Since then, I don't see notifications for visual voicemail.

I fixed this problem by simply removing my sim card and putting it back in.

Evidently dis- and re-connecting to the cell carrier was enough to do it.

I'm running Android 5.1 on a Moto E2.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.