I have had this problem on both the Nexus 4 and Nexus 5 (of all phones).

I have a file, it is the same ringtone file I use on all my phones, it is an edited mp3 of a song I like.

I put this file in the "Ringtones" folder of my device.

When I go to change my ringtone, my new file is not available as a selection in the Android settings.

Rebooting the device does not cause the new file to be detected.

What I end up doing EVERY SINGLE TIME I have to add this ringtone file (I wipe my device occasionally) is finding the "Media Storage" app on my device and clearing its memory. At this point the phone thinks there are no ringtones, but then once I reboot, all the old ringtones are there along with my ringtone which has been in the same location the ENTIRE TIME.

So I have a workaround, but can anyone tell me where I am going wrong?! This is driving me nuts! Is anyone else seeing this problem?

I have to be missing something simple because all the internet forums I am reading are all straightforward "just put the file in the ringtones folder and it works like magic" which is very frustrating.

EDIT: Some additional info, I have had the file there for a couple days now, just to see if that makes a difference. Rebooted the device over a dozen times in the last couple days. The file still is not available as an option.

EDIT 2: See comments below. Seems to be something to do with how I am placing the file there, but still strange that media scan does not pick it up on reboot. Anyone know anything about media scanning? Maybe it is optimized on boot to skip folders like the Ringtone folders since those shouldn't change frequently...?

  • Why it doesn't turn up immediately is easy: that requires the media scanner to add its name/location to its database. But a reboot should have triggered that definitly, so something seems to be wrong there indeed. How did you add the file? Have you tried doing so via MTP/UMS (while the phone is connected to your computer)?
    – Izzy
    Commented Dec 30, 2013 at 19:57
  • @Izzy I added it using ES file explorer and copied it over from cloud storage (Ubuntu One). ES signs into U1 for me and I do everything in app from there. This is usually how I always add the file since I know it is always on my cloud storage. I just tried plugging it in, removed the file, unplugged and replugged, added file, unplugged and it was there in my ringtones without reboot. I guess the app is not triggering a media scan correctly, still weird that it doesnt pick it up on reboot till I clear the media storage app memory :/ :/. File cant be corrupt, I just re-copied it now... :(
    – gnomed
    Commented Dec 30, 2013 at 22:24
  • You are probably right about the app not triggering the mesia scanner. However, a reboot should trigger it. Let me make a guess: all affected devices already run Kitkat? Because starting with that, media scanner does no longer do a full scan AFAIR (at least the apps triggering it no longer can do so in the "old way"). If I remember correctly, media scanner must now be pointed to the changed files directly.
    – Izzy
    Commented Dec 31, 2013 at 0:21
  • One more note: If my guess was correct, and your devices run 4.4.2, you might have hit a Kitkat bug (Google Translate version). The work-around described there is pretty much the same you're already using.
    – Izzy
    Commented Dec 31, 2013 at 16:04
  • @Izzy I am pretty sure this happened on my nexus 4 pre-kit kat. That is a good point though, I have noticed that change to the media scanner as well in kit kat. Oh well, I'm stumped.
    – gnomed
    Commented Jan 1, 2014 at 0:39

10 Answers 10


What solved it for me - I had a hyphen - in my OGG filename, changing it to an underscore and restarting the phone (Nexus 5 KitKat) made it show up

  • Confirmed for Lineage 14.1 and Notifications. No hyphens.
    – Mantriur
    Commented May 17, 2017 at 22:00

If you just copied over the file then it's permissions are like set at 600. chmod the file to 644 so it is WORLD READABLE. so,

chmod 644 /sdcard/ringtones/blah.whatever

also a filename with a space in it could cause an issue, do a rename anyway so if the files name is blah blah.whatever , rename it to blah_blah.whatever

Lastly if the above are no go or already sorted correctly, goto settings-->apps and locate media storage. Force stop it, clear it's cache and then reboot. Note if you want to clear all it's data, pull your ringtones to a different directory first JIC then after your clear all data , move them back to your ringtones directory. If you are rooted just copy the file over to the correct place in /system/media/ and set perms correctly [644] and reboot.

  • In terms of a space in the name, you should just be able to put speech marks around the file name and extension. Or was it the whole path...
    – Dan Brown
    Commented Oct 15, 2015 at 20:50
  • That was my first reflex, but chmod would fail silently, permissions remained at 660. For me it was the hyphen.
    – Mantriur
    Commented May 17, 2017 at 21:59
  • @Someone hmm, if chmod is "failing silently", try chattr -i <filename> you might have immutable bit set though, that would be odd, else , you are not root OR file format may not be supported or "corrupt". Use file utility to check the file.
    – moonbutt74
    Commented May 30, 2017 at 21:47

I have a setting on my phone. settings - audio profiles - individual profile setting - custom ringtone. here I can add any MP3 to the list of phone recognised ringtones. if you have such, then you're golden.


I had the same problem, in my case I use my favorite song as alarm, since I install new apps for some reason I can not remember I force to stop the default app for music, and I went back to it and run it again and I was able to search for music files again,,,, it seems no default app is running and that's why can not run the option. :)


Try finding the song through your device music player. Play the song and while it is playing, select options then set as ringtone.


I came across the same problem. My new Moto E (2nd gen) would not play the ringtones I copied from my computer to my phone. I solved this problem by ignoring the message that I get from my Moto E about converting the files over to WMA files (I left them as .m4A files - music files) when I copy them from my computer to my phone and copied them back into the ringtones folder as well as the music folder. I opened Google Music player and played them and then assigned them to my alarms. What a pain in the neck! It is fixed now.


Some of the MP3 Files may have different "file name" and "file title", we can see file title in laptop using : Right click on the file -> Properties -> Details. MP3 ring tones listed in Android by "File Titles". Ex: I downloaded a file named "Notify.MP3" and it is listed in Android Ring tone as "Morning Alarm 4" Note: I'm using Android-L


I'm sorry this is so long, but if you're still desperate it might help. I've unsuccessfully been through a lot of online advice. I have a generic phone running 'N' (that's Nougat, right?), a Blu Vivo XL2, which has two SIM slots. I'm only using one of the latter at present, and for some reason the guy at the store put the SIM card in slot 2. I took T L Kannan's advice to give the ringtone file a title in addition to its name (by going back to Audacity and not skipping the Metadata part of Export audio and of course placing this version in the phone's Ringtones folder), which may or may not have helped. Real resolution came from a bizarre experience I hadn't heard of before.

  1. Tapping Settings->"Sound and Vibration"->"SIM 2([network name])Call ringtones" (other choices SIM 1, Notification, Other...), which brings up the list of built-in ringtones
  2. tapping a little icon at the bottom of the display labeled "Ring DIY"
  3. swiping down through the resulting endless list of every blessed sound file on the phone to find and select my file at the very bottom.
  4. This brought me to a new screen which looks like a bare-bones sound editor with a big red Start button, which plays the file. Great! There's also Cancel and Save at the top.
  5. tapped Save, which brought up a screen with the snarky message (no kidding!) "Oh well--Good--You should name this ringtone" with the (already-named) file in an edit box and a Save button at the bottom. It wouldn't let me not (re-)name the file (I just added a digit to the end) and Saved. (This process BTW seems to save duplicate copies of the file under the modified names in a subfolder of Ringtones named "diy", and I think I'm up to [Filename]4 by now.)
  6. This leads to a screen "Congratulations~Saved successfully!" with "Make ringtones" and "DIY again" buttons below.
  7. Tapping the former brings up a popup at the bottom labeled "Make Ringtones" and a single choice; "Voice call ringtones", which led me to
  8. a choice of SIM 1 and SIM 2. Tapping one of them leads back to step 6 again. Backing out of there via "<-- Ringtones" at the top takes me back to step 2, the list of built-in ringtones (and where, incidentally, still no version of my ringtone is listed!) Backing out one more step gets back to the basic Sound and Vibration screen, where my ringtone name is now listed in a small, gray font under the SIM 2... item

But wait! Testing the new tone by adjusting the Ring volume slider still plays the default ringtone! Apparently this is tied to the (in my case, empty) SIM 1 slot, because repeating all of the above nonsense allowed me to attach yet another, differently-named copy of my ringtone to SIM 1, with the result that the volume slider finally plays (the equivalent of) my new ringtone!

That's ALL there was to it!

Hopefully it'll work when I get a real call.


I had the same problem. I copied the file from Dropbox on my phone into the Ringtones folder.

The file was not found for use as a ringtone. I deleted the file after several hours.

Then, I plugged the phone into a PC and copied the file from the PC. The ringtone was found instantly.

Don't know why. Hope this helps someone.


I put 100 new ringtones onto my SD card but they wouldn't show up when I tried to select them. So, I played a single MP3 ringtone in my music player, then all 100 new ringtones suddenly appeared in my 'select phone ringtone' in settings/sound

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .