2

I've tried out the SMS feature of Hangouts app, which allows you to handle SMS within itself instead of the default one.

I didn't like it for certain reasons, so I disabled it.

However, for some reason, almost each time anyone sends me something via Hangouts (from a PC for example), I get it in both Hangouts and via SMS (with phone number that looks like "1000274" ). That's right - I get 2 messages - one for hangouts and one is an SMS message shown on the normal messaging app.

Why does it happen? How can I stop it from happening?

I hope it's a bug and that it will get fixed soon... :(

NOTE: I have Android 4.3 on a Galaxy S3 I9300 device.

  • Are you using a Google Voice number? – Mr. Buster Apr 11 '14 at 16:25
3

Go to

  • Settings -> Under data usage tap More
  • Tap Default SMS app and select your SMS app

Source with detailed instruction: http://howto.cnet.com/8301-11310_39-57613499-285/manage-default-sms-app-on-android-4.4-kitkat/

  • sadly I don't have kitkat. I have Android 4.3... – android developer Jan 1 '14 at 16:00
  • @androiddeveloper, does this not work on 4.3? – dotVezz Jan 1 '14 at 16:33
  • @dotVezz android 4.3 doesn't have this option on the settings of the device. I was talking about the feature within the Hangouts app... Only android 4.4 has the ability to choose which app is the default SMS app... – android developer Jan 4 '14 at 10:36
0

I've recently flash a custom ROM called "OmniRom" (AOSP, Kitkat based), and I think this problem is now gone.

Not sure why it occurred, and why I don't see it anymore.

Maybe it's because of a bug on 4.3.

0

OK, I think they've fixed it some weeks ago, as I didn't notice any new SMS message that comes after a real hangouts message.

0

The functionality is different with Kitkat as you can choose your default SMS application in the Wireless & Network settings. Below is for 4.4 and for 4.3 and below. Open the application.

For Android 4.4+ (Kitkat) (As per the above):

Click on Menu then Settings.

Click on SMS.

Click on the setting "SMS Enabled" under the General heading and change your default SMS application.


For 4.3 (Jelly Bean) and Below:

Click on Menu then Settings.

Click on SMS.

Untick the setting "Turn On SMS"


(source: cbsistatic.com)

  • well as i've already written, i've already disabled this functionality. the problem is that for about half of the messages i get via hangouts, i also (in addition) get an SMS containing those messages. – android developer Jan 3 '14 at 13:50
  • Have you uninstalled hangouts and reinstalled it? Have you installed any other 3rd Party apps for SMS and reset your default? I know my answer is generic, but I wasn't sure WHAT you had disabled already. I've not seen this issue on the S3, S4, Nexus 4, Nexus 7, HTC One, HTC Desire X or any of my other devices. I wanted to give a generic answer, and assumed you had cleared all data, reinstalled, rebooted etc. Are you getting IMs from Hangouts converted into SMS? The wording is not clear to me on your question. Are you rooted, running custom firmware? – RossC Jan 3 '14 at 14:44
  • I'm not sure how should I write this problem. For almost each message I get via hangouts (that someone writes to me via his PC, for example), I also get the exact same message to both hangouts and the SMS messaging app, and it's really an SMS message, with a weird phone number as I've written. I've now updated my question. hope now it's clear. – android developer Jan 3 '14 at 16:20
  • Ok that's totally clear now, that's very very odd. Did you reinstall hangouts from scratch (delete data and cache, uninstall and reinstall)? Do you have a different SMS app, or the default one that came with your device. Sorry I can't be of more help, but I'll keep looking for you. Something very odd going on there. – RossC Jan 3 '14 at 16:23
  • I've now tried to clear the data of the app. It didn't work. In fact, I think it got worse (or maybe it was like that before too) : now some messages are sent only as SMS, plus video calls request don't always get to be received ... :( – android developer Jan 4 '14 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.