My son got an iRola DX752 with Android 4.2 jellybean for Christmas. It worked fine Christmas and now it won't turn on. It is fully charged.

What can I do to get it to work?

  • I'm assuming this is a tablet of some kind. Can you take out the battery then put it back? How long are you pressing the power button to get it to turn on? It seems like this might be a defect and the device should be returned for repair or replacement. – ale Jan 1 '14 at 21:35
  • I purchased the same unit before Christmas and I've used it 4-5 times. This weekend, both the power and the sound button (which I don't think ever worked) popped out. This product is definately defective. – user50207 Jan 6 '14 at 23:26

You can do a factory reset . To do this you press the Vol UP and power key together .If that wont work, try the Vol Down as I may be wrong . You should at some point of messing with the buttons get a Broken Android picture of the robot . Then you play with the buttons and get to a menu that has "Factory Reset "

Not the answer you're looking for? Browse other questions tagged or ask your own question.