Just upgraded the operating system on a Galaxy S II from 2.3 to 4.1.2.

After upgrading we are unable to update any apps because it says the phone is too low on memory. When I look at the storage breakdown I see:

  • Device memory has 1.97 GB and only 189 MB is available (which is where it says the issue is).
  • "USB storage": 9.86 GB free of 11.36 GB.

"USB storage" appears to be where picture/videos/music/ringtones are stored. Oddly enough, it also says that this is where the applications that are unable to be updated are stored.

We tried the solution found here, but it didn't seem to help.

Does anyone know what might be going on?

  • 2
    It might help to look at the questions tagged insufficient-memory to see if it has been answered, here's one example
    – t0mm13b
    Commented Jan 2, 2014 at 0:32
  • I did (and I saw the one you linked). The question I provided a link to in the post offered the same fix, but through a menu instead of needing the phone to be rooted. But as I said in the post, the fix did not work for this issue.
    – Ryan
    Commented Jan 2, 2014 at 16:17

3 Answers 3


did you make a nandroid backup before your update? If no then here is the problem and solution that I faced recently.

On my Walton primo g1(a local branded phone manufacturer is Gionee) I got an update from 4.0.3 to 4.1.1. So as-usual I decided to update my phone. But after updating my phone I faced frequent crash and had to reset my phone to update it again. However, after this time whenever, I went to market to download anything it prompted the low device storage message. Even I am using my browser and surfing on net, it freezes and gave me a notification that low memory on device. So I looked into my device storage and found only 13 mb were free on my rom.

Solution: So, I decided to root my phone and to use a custom rom. But after rooting when I went to root/data/data file path, I found all those apps data that I installed previously on ICS rom are still there, which is about 350mb (internal space 500mb and 412mb is user available on my phone). So, I just went to CWM and did wipe data+wipe cache+wipe delvic cache and re-flashed the rom. And my problem was gone.

I don't know about your case here, but it seemed way like my problem. So, you can also give that a try. Just wipe data,cache and delvic memory and flash your phone with the stock JB(which you can download from the samsung website) rom again with odin. And this should fix your issue.

Hope that helps


Here is what could have happened. When you went from 2.3 to 4.+, Android created user folders. So now you have all of your data in /storage/emulated/0 where it was /storage/emulated/ before. Each number, is the user on the device, so if you have multiple folks using the device, they have a folder for all of their apps and stuff. Now it has all the old stuff in the emulated, and all the new stuff in emulated/0.

When you look at your storage through an app, it ignores anything that is under the /0/ folder, and therefore you can't see the extra space that's being taken up.

The only way that I had to deal with that was to wipe the device clean. If you aren't rooted, make a backup of your photos, wipe the device, and you should see the boost in your on-board storage.

Source: had this happen going from ICS to JB on a Samsung phone. Going into CWM/TWRP (don't remember which) and deleting contents from /emulated/ solved the problem.


The reason this happens is that the newer versions of Android will only let apps install to internal memory. On older versions (such as Gingerbread) an app could install on the SD card or be moved there. For the newer versions of Android an application can store it's data on the SD card if that's the way it is designed, but the app itself will be installed to internal storage. This is a problem I ran into a lot working for Verizon and customers were not pleased, as you can imagine. Outside of rooting your phone I am not aware of a good option to fix this issue.

  • Somehow I believe its' not correct! Whether an application should install on internal storage or sdCard depends on the configuration written in an android application. For instance, if I want my application to be installed on sdCard, I can easily do that by providing some extra information/code in AndroidMenifest file. Like that I can also provide command whether a user can backup/move this application to SDCard or not. Commented Jan 11, 2014 at 8:29
  • I would like some more info on this topic as well. I was fairly certain based on numerous articles on on the web such as these - 1: androidforums.com/samsung-galaxy-tab-2-10-1/… 2: forums.androidcentral.com/sprint-samsung-galaxy-s4/… 3: beranger.org/2013/06/14/… I know it's something I haven't been able to do with any of my Samsung phones since ICS. Perhaps a Samsung thing? Does anyone else have a definitive answer?
    – Roan
    Commented Jan 13, 2014 at 3:21
  • May be or may be not. But the thing that is bugging me is that, my Galaxy S4 (international version) works fine on this issue. Got my phone rooted but till on Samsung Touch Wiz. However, I have not faced this problem till now. Another thing, Yes! you are correct! you can not move apps to sd card but you can move its content. I also wanted to mean that,however. So, the last thing that I can say, may be this is the limitation due to The Samsung Touch Wiz over android? \ Commented Jan 13, 2014 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .