9

I have a Samsung Galaxy S2 with Android 4.1.2 JellyBean.

When I get notifications in SMS or from Facebook, I see a red notification with number (notification badges) on the application icon on home screen.

Is there a way to stop that? I stopped all notifications from Facebook app but I still get notification badges on home screen.

  • I have yet to find a way to do this with Touchwiz based ROMs I'm afriad. You could use an alternative launcher, and disable it (it is disabled in Nova Launcher by default). Or if you have root you could look for an Xposed Module, again though I haven't fond any of those either. – RossC Jan 2 '14 at 12:27
7

I found this article that explains how to disable it on the Galaxy Note i717. I don't have a SG phone but I imagine the solution would be similar for yours.

  1. Go to Settings > Manage Applications > swipe laterally through the top tabs until you reach "All"
  2. Scroll down to locate BadgeProvider and tap on it
  3. Click on the Disable button and confirm that you would like it disabled.

This will disable all badge notifications as there is no per-app setting interface.

  • Yape. That does it :) Its doesn't remove badegs already there but it does prevent new badges notification to appear. Thanks – RoyZo Jan 5 '14 at 5:10
  • 4
    This sounds like disabling badges for all apps (incl. e.g. Messaging/SMS). Too bad there is no disabling per app like there is for notifications. – Daniel Sparing May 2 '14 at 11:39
  • @DanielSparing that was not what the OP requested, so I didn't think to make any special note that it was a global setting. But you're right, it disables all badges. – filoxo Jun 10 '14 at 22:26
  • 1
    One additional point that I would like to make is that the users have to scroll right 4 times to reach the "ALL" tab where they can find the "BadgeProvider" service. At first, it wasn't obvious to me so I thought I didn't have that option. Glad I found it, so happy!! – HelpMatters Aug 7 '15 at 14:42
  • 4
    Unfortunately it seems that this does not work on the Galaxy S6, at least with Marshmallow. The BadgeProvider service cannot be disabled. – msridhar Apr 26 '16 at 0:52

protected by Community Aug 13 '15 at 16:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.