2

My phone doesn't get a mobile signal anymore after installing CyanogenMod 10.1.3-i9100 on my Samsung Galaxy S 2. The IMEI is the same as printed in the battery compartment, Wi-Fi is working fine, and it finds mobile network operators, but even after setting it to "Choose automatically" it doesn't connect. When I try to phone someone, it says "Mobile network not available."

According to a CyanogenMod FAQ there should be an option Settings → Wireless & Networks → More → Mobile Networks → Network Mode, but there is no such option.

In "Wireless & networks" I see the following:

  • Aeroplane mode
  • VPN
  • Tethering & portable hotspot
  • Mobile networks
  • Mobile broadcasts

In "Mobile networks" I see the following:

  • Data enabled (checked)
  • Data roaming (unchecked)
  • National data roaming (checked)
  • Access Point Names
  • Use only 2G networks (unchecked)
  • Network operators

According to the Android Testing Menu (*#*#4636#*#* → Phone information) the network type changes between "HSDPA" and "GPRS". I'm not sure if the "Set preferred network type" setting is the same thing as the "network mode", but changing it from the original "WCDMA preferred" to "LTE/GSM/CDMA auto (PRL)" doesn't seem to help (tried restarting radio afterwards as well).

  • When you go to settings what Network options are there? WiFi etc? – RossC Jan 6 '14 at 13:13
  • What do you mean by "mobile signal"? Are you talking about mobile data (in this case, you should check the "Access Point Names" menu, and probably will have to add an appropriate APN), or does it include the "phone signal" as well? – Izzy Jan 6 '14 at 13:42
  • Have you flashed the correct baseband on your device? The baseband from one version of Android may not work with others and you may lose wifi or 3g or whatever. – RossC Jan 6 '14 at 14:25
  • @RossC Could you please be a bit more specific? I used the latest stable version of CyanogenMod for my specific device. – l0b0 Jan 6 '14 at 14:33
  • The baseband is the 'modem' for your device. You usually flash it via Odin in the 'phone' section. The modem may not be fully compatible with your device and this is why you have the issue. I had to flash a new modem on S4 once I flashed a 4.3 Jellybean ROM on the device. Try #1234# or the appropriate code for your device and it should show your current Firmware and Baseband. Here is the modems for your device: forum.xda-developers.com/showthread.php?t=1455188 – RossC Jan 6 '14 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.