0

I got a Motorola Moto G a few weeks ago and unfortunately it came with what I suspect is a failing accelerometer. I say that because when I open any level (bubble) application it reads random numbers in a wide range, even after the app calibration and on a flat surface (no sensor calibration on the phone settings).
Let me show you the video to make it easier to understand: http://youtu.be/FD35Uk4HmXo
I tried four different applications and all of them show the same symptoms- the bubble moving randomly in almost one full degree. When I talked to Motorola technicians they blamed the application(s), so they recommended me to return the phone and get a new one. To my surprise the new device (the one shown in the video) does the same exact thing!
Now I wonder, do I have bad luck and got two defective Moto G? Or they messed up and put a bad sensor in the devices? Or I am doing something wrong!?

Does anyone have this issue with their own Moto G?
Thanks :-)

5

From what I can see in the video, the fluctuations are within about 1° in the first app, and 0.5° in the second. That's not exactly "random numbers in a wide range".

Accuracy within 1° is acceptable for most intended use cases: Mobile games, screen orientation, gestures, etc. It's quite possible that Motorola decided to use a cheaper sensor since the phone itself is intended to be a very low-cost device.

I wouldn't say that it's defective. Possibly subpar, but not defective.

  • I never thought about it that way- Motorola using sensors of bad quality regardless the price has never crossed my mind. Unfortunately, like I also explained technical support, this is a tool I use very frequently at work and I can't afford this sensor to be this variable (not even in the half degree application). Now, I really believe in that word you used: subpar! Thanks for your answer, dotVezz!!!! – Claudio Jan 7 '14 at 19:34
  • If the answer helped you, feel free to mark it as accepted and upvote it if you haven't already =) – dotVezz Jan 7 '14 at 20:26
  • Cool, in another stack exchange site I had to wait for like 24 hours before accepting an answer. Thanks!!! – Claudio Jan 7 '14 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.