In my Android in notification bar I see message Storage space running out. Some system functions may not work.

When I check I see 188 MB free in device memory and around 10 GB in USB storage.

I re-installed Android OS a few times.

It helps for about a couple of months then the problem returns.

If I delete some applications or data it helps for a few hours to a few days.


  • Why do I get Storage space error if there is a lot of available space?
  • Can I join device and and USB memory? Will it help or at least delay the time while the problem return?
  • Any other advice how I can deal with this problem?
  • Have you tried clearing the logging files? If not then you can do that by, dialling *#9900# and select delete dumpstack. See if this can help you out with clearing some of the space for you. Commented Oct 29, 2014 at 6:06
  • I've just added the insufficient-memory tag to your question. Please check its tag-wiki, which should get you started (contains some first-aid plus links to more details).
    – Izzy
    Commented Oct 31, 2014 at 12:46
  • I suspect it's a problem with Mailbox, since it's the crashing (together with "android-process-acore"), and my system will work for some time after I "clear cache" from Mailbox. Commented Oct 31, 2014 at 14:24
  • I solved by reseting my phone to factory configurations... :/ Commented Nov 5, 2014 at 21:55
  • It has to be dialed into Samsung's own dialer.
    – reticent
    Commented Jan 7, 2016 at 9:40

8 Answers 8


On Samsung phones, type in the dialer *#9900# then choose the second option: "Delete Dumpstate/logcat".

  • Well, this solution do not work on 5.0.1 Android and I suppose for 4.x also.
    – yilmi
    Commented Jan 29, 2015 at 16:09
  • 4
    This is a Samsung specific thing, it does not work on other phones. Also, you don't need to dial (call) it. After pressing the the last # character, the menu appears immediately. Commented Apr 25, 2015 at 23:36
  • Does not work on my Samsung Galaxy S4. As Gayle said, nothing happens after punching the code into the dialer. If you hit the phone icon to dial, "welcome to Verizon Wireless, your phone... ...cannot be completed as dialed" Commented Oct 28, 2016 at 20:40

Even though there already are many answers, there is actually none answering two main questions and the third one just for a case of dumpstate problem. Read just bigger text if you're in a hurry.
Also, I'll explain why solutions mentioned in other answers help only sometimes. And offer another solution in case cat is not your problem.

  • Why do I get Storage space error if there is a lot of available space?

It's not an error, it's by design. The trigger for low space is quite high, usually 10% OR 500MB, whichever is lower.

"some system functions may not work" - that's not precise, some WILL NOT work.
Synchronize, some download functions, installing apps, hangouts and many Google apps.

If you'll ask:

  • Why there is less than 500MB available?

then the answer is, that it's either that you used it up unknowingly, or that there is a problem with something stuffing up your storage space.
If you used it up and want to check with what, follow the answers saying clean up your space, if you didn't, it might be variety of other problems, but most likely it's logcat which is leaving huge dumpstate files behind. In that case follow the answers mentioning logcat or log or dumpstate. Or jump to my last paragraph below.

Which parts of memory are monitored for free space.
we may distinguish two model situations according to the FS structure in an Android phone:
(Note, that what I call INTERNAL STORAGE is not standardized name, usually it's weirdly called sdcard, might also be called USB storage as it possibly is in your case.)

  • DATA partition is separate partition from INTERNAL STORAGE

INTERNAL STORAGE is not monitored and you can fill it up to zero free bytes and nothing happens. DATA storage is monitored, on galaxy S2 it's 10%, from 1500 MB, 150MB must be always available.

  • one partition for both DATA and INTERNAL STORAGE

INTERNAL STORAGE is emulated as a separate partition with different permission rights. It also has a "fuse" or reserve, which will not allow all space of the real partition be used. Files on INTERNAL STORAGE are actually located in /data/media/

old models, maybe up to Android v2.3, also has DBDATA partition, which was separately monitored - if I remember this correctly

A change from one system to another might have been done by a FW update. I still remember when such update removed thousands of my holiday pictures on Galaxy Note2. An INTERNAL STORAGE partition was removed and mounted on DATA partition using FUSE, there was 100MB difference when I checked free space on each.

So, depending on a data structure you have, you need to keep for example 400MB of free space on an INTERNAL STORAGE which might, using df or a free space analyzer app, show as 500MB free space on DATA partition.
Note that,
- the minimum size is different for each model and sometimes also FW version.
- You need to wait for about a minute to see if the notification will clear itself after you make some more space available.

second question:

  • Can I join device and and USB memory? Will it help or at least delay the time while the problem return?

Fast answer, NO. And if it would help? Yes, it would help to avoid the problem of low space, by means of having bigger total storage.

To elaborate:
IF "USB memory" is pluggable SD card, or a pluggable device in your case, or if it's located on a separate memory chip, as it's on Tab 1 and phones from similar age, then it's not possible to join it with DATA partition.
IF "USB memory" is an INTERNAL STORAGE in your case, you can join them but it's not an easy or safe process. In other words, if there is not a guide by someone who have successfully done that on the same model of a phone as is yours, we might also figuratively say, NO, it's not possible.

While searching the Internet for the guide, be aware that it wasn't a clever idea to name the INTERNAL STORAGE as "USB storage", because there is also a real USB storage. You'll find a lot of solutions for enabling USB for storage drives, so called USB OTG feature, don't get diversed.

basically you need to:
re-partition your memory chip, called eMMC for some reason, delete USERDATA - what is a partition name for INTERNAL STORAGE and merge the freed space with DATA partition.
then find/compile fuse module which would take care of emulating the partition with full permissions for media_rw or some other user,
edit init script, to create a mount point for new INTERNAL STORAGE,
many more changes and tweaks which I can't think of.

third question:

  • Any other advice how I can deal with this problem?

The best option, if you have a root access, is to

lower the threshold of the minimum free space.

You can put it down to 1%, possibly even less. That means 20 - 120MB of minimum free space.

It involves sqlite3 editing but although it might look difficult, it's very straightforward process. Just follow any good guide and you'll do it alright. THIS guide looks splendid or there also are sqlite3 editor apps, or find another guide using THIS gugl link.
There are two things to note:
- different guides are mentioning different table names. 'Secure', 'system', 'global' or even 'gservices'. The truth is, it was applicable in different tables through different Android versions. Now it should be in 'global' before it was in 'secure' and before that 'system'. My advice is, just put it in all of them, you will not hurt anything. That means follow the guide you'll find and repeat the steps while replacing the table name with each of those names I mentioned above.
- you might find settings.db file locked and not writable even with root, it happened to me when ICS came out. But didn't happened since. Anyway, in that case, boot into recovery, pull the file out, edit on PC and push back in.

If 1% (around 100MB if you have 16GB chip) is still too much for you to waste, as it was for me, add sys_storage_threshold_max_bytes value too, I have 20000000 = around 20 MB and never had much of a problem, although many apps don't have available space checking and will error without stating the reason, so you need to keep in mind it might always be free space issue. There is -OR- statement between those two variables. Don't put less than 20 there because if a certain system file which resides in /data folder will fail to write, your phone might not boot. I find 20MB quite safe as there are no files larger than that in /data, while excepting /data/data, /data/app/ and dalvik. and if a file will get broken in /data/data, no big deal. Data reset of that app will solve it.

If something is eating up the free space

If you suspect that there shouldn't be so much space taken, or you just want to clean up space, as in a couple of other answers here, I also recommend DiskUsage to help with the job of visually locating what is taking how much space.
In the DiskUsage app, in the second column, the 'media' stands for INTERNAL STORAGE and Apps represent /data/app and /data/data - space taken by apps.
The 'System data', in green color, on the bottom is the rest of /data folder and shouldn't be too high. 300MB is fine, over 1GB is probably a problem.
If this System data is too high, it's possible your logcat has gone wild and created tons of dumpstate postmortem poems. In that case, and only in that case, will all of the other answers here be applicable. Meaning that deleting this gigs of wasted space in folder /data/log or dialing a *#9900# , which by the way is not a valid command for every device, will bring your Android back to a good mood. For how long is a question of whether the culprit which caused the excessive logging has been patched, or removed.

  • 1
    "The trigger for low space is quite high, usualy 10% OR 500MB, whichever is lower." Can you put a source to that? I know about the 10%, but instead of the 500MB the number was much lower when I checked last time (25MB, see e.g. here. Never found an "official reference" to that number, though.
    – Izzy
    Commented Jan 14, 2018 at 11:12
  • 1
    If you refer to my use of the word usually, I wouldn't say it was fairly used adverb today. That was what all my phones were set to. But this might not apply for earlier or later models, or for brands other that which I had then. On my devices, 500MB was a fixed amount. I was testing this using 1MB files. If I duplicated one to leave 499MB of free space, notification appeared, when I deleted some to have 501MB free, it disappeared. When I edited the sys_storage_threshold_max_bytes value to 20000000, I've been able to have just 20MB of free space without the full memory notification.
    – papo
    Commented Jan 19, 2018 at 9:01
  • Thanks papo – that definitely nails it. Special thanks for mentioning that constant! And admitted, those 25MB where in the times of Eclair/Froyo where devices had quite limited storage altogether. Tag wiki updated :)
    – Izzy
    Commented Jan 19, 2018 at 10:14

I had the exact same problem. Had the phone into the Samsung Service location a number of times, where they performed a full software recovery twice and then replaced the mainboard, but the problem persisted.

I realised that the memory logs, which were filling up the logs file, seem to be connected to a network issue and decided to try and obtain a new sim to see if this helped. I got the new sim yesterday and everything that seemed to kick in the log files and fill up the system memory seems to be ok.

Previously, it might be ok once I had cleared the logfiles (*#9900#, delete log files) for a few hours, but then all of a sudden the log files would start again. Within a few hours, my phone (Galaxy Note) would start becoming unresponsive, and I would get the Storage space running out message and my system memory would be down to 100mb rather than 1.4g.

After weeks and weeks of the same problem I am reticent to say that things are completely resolved. Putting the new sim in seems to have solved the problem for me.

  • YES! Swapping my two SIM cards seems to have solved! Thanks! Commented Oct 31, 2014 at 11:25
  • Ops, it started to fail again after some minutes... Commented Oct 31, 2014 at 14:12

May be you should check this link, hope this will solve your problem.


  1. Root your phone.
  2. Download the Root Browser app fro here
  3. Reboot
  4. Open the newly installed Root Browser app, a pop up will come stating if you want to give the app root permission. Grant it.
  5. Navigate to /data/ and delete the folder log
  6. See the magic :)

Well, the best way to zero in on what you can get rid of to free up storage space is an app that maps out your storage use such as Disk Usage, a cleanup app such as SD Maid, or a file manager that can search for large files.

But since you're facing the Catch-22 of needing to free up some storage before you can download any apps that help you free up storage, start with the stock file manager, called My Files:

enter image description here

Tap All Files, then Device Storage, then navigate to the folders where you're most likely to have large files you can get rid of. Some likely candidates are the following default folders:


In order to see the file size in the list, so that you don't have to long-press each file and select Details to see how large it is, tap the menu button, select View By, then select List and Details.

To help you determine where you're using the most storage, you can go to Settings > Storage (the exact location of Storage may vary depending on your device and OS version, for example on a Samsung Galaxy S it's on the More tab):

enter image description here

If, for example, you see the largest number under Pictures, videos, you probably want to start with the folders DCIM/Camera and Pictures; if the largest number is under Audio, look in Sounds and Music for files to get rid of.

Since it's a tedious process using the stock tools, I recommend only doing it this way until you have enough space to download some apps that can help you clean up more efficiently.


On a Galaxy S2 with Cynagoenmode 11 running, I did below steps to free space. This clears all unnecessary logs generated.

> adb shell
$ cd /data/log
$ rm *

I have been through this storage problem. This is the solution to your problem only if you have "root" access. This problem occurs due to old application data of apps which have not been uninstalled properly.
Download "SD Maid" from the Play Store. You can search for application data which exists on your device in spite of being uninstalled. Clear the corpses and retry installing the app you want to install and it should work.


I think APP2SD will work for you. With this you can set default app location to USB or ext card.For this I can suggest you to download and install AIO Toolbox. It has tonnes of features builtin. See if it might help you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .