1

I recently tried to add a custom boot animation to a Galaxy Note 3 by adding a custom bootanimation.zip to /system/media and then flashing a custom binary for the boot animation made by a user on XDA. That worked, the phone booted with my animation instead of the stock animation.

Though I noticed that it was rotated by 90°, so I replaced the bootanimation.zip with a fixed one, though after doing that the animation didn't change. Flashing the binary again didn't change anything either, neither did formatting the cache. I tried it with a totally different animation from XDA but that didn't work either so its not fault of the zip file.

The strange thing is I can flash the original .qmg animation from Samsung but then flashing the binary again just gives me my old rotated boot animation.

Now I wonder why is that happening? Does the system copy the animation to a different place and that's why replacing the original zip doesn't change anything? It sounds like something Android specific, I somewhat doubt the binary is doing that.

5

I had a similar problem on CyanogenMod and it turned out to be broken permissions. I tried the following which worked in the shell only for whatever reason. You need to be rooted and have ADB installed. The following commands mount the system partition for reading and writing, copy stock bootanimation zip (change location, or skip), copy custom bootanimation zip to data/local, and (re)applies correct permissions to media folder and zip files, and finally reboot (if you want).

adb shell
su
mount -o remount,rw /system
cp /sdcard/download/cm/bootanimation.zip /system/media
cp /sdcard/download/bootanimation.zip /data/local
chmod 775 /system/media
chmod 644 /system/media/bootanimation.zip
chmod 644 /data/local/bootanimation.zip
reboot

If you want to restore to stock, simply delete the data/local version. If you want a new one, replace it while keeping the system/media version intact. You can also create your own bootanimation using this guide from XDA.

0

This saves my butt after 3 days of trying everything.

-Install adb driver & tools first
-Connect via usb
-Open command prompt

Note: Assuming you have the original as bootanimation.zip1 in the same location or use new one that might work (in this case you must add another line after mount to push the new file first in the same location - google how to "push file")

While bootanimation.zip keeps playing, paste below(quickly each line):

adb root
adb shell mount -o rw,remount /system
adb shell cp -f /system/media/bootanimation.zip1 /system/media/bootanimation.zip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.