2

I plugged my original Nexus 7 into my Mac earlier today to build an application onto it for testing. It failed, and then I realized that the tablet did not appear to actually be connected to the computer.

Symptoms: Tablet charges, but no notification about being connected. Tablet does not appear in ./adb devices (nor in ./fastboot devices when device is in bootloader), and Android File Transfer will not find it.

Tried: Rebooted both tablet and computer, tried different USB cables and USB ports. Tried MTP, PTP, and neither. Tried USB Debugging on and off.

My Nexus 4 connects to the computer just fine. Both N4 and N7 are running Android 4.4.2

UPDATE: Tested my roommate's Nexus 7 (same model) on my computer, and it connected fine. Tested my Nexus 7 on his computer and saw the same lack of connection

EDIT: now fairly convinced that it's a faulty hardware USB port on the tablet. Wiggling the cable will cause the device to show "USB Debugging Enabled" and "Connected as Media Device" notifications, though the computer still doesn't recognize it

bumped to the homepage by Community 10 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

You can try another way: wireless connection via Wifi. Some apps such as Airdroid, Web PC Suite can help you transfer files by Wifi. Connect the two devices by scanning a QR code, then you can send files between the two devices easily.

  • Welcome to Android Enthusiasts, Esther! You might have missed an important point here: OP is not asking for "file transfer", but explicitly wants a USB connection (in this case, for debugging apps using ADB). While there's also the possibility of using "ADB via TCP" with a WiFi connection, that is at best a work-around, not solving the OPs USB issue. – Izzy Aug 25 '14 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.