0

So I have Nexus 7 (not the 2013 one), Wi-Fi version, with TWRP recovery, version 2.6.3.1 installed.

When trying to install some roms, for example, SmoothRom, or PAC, installation fails with following message:

assert failed: getprop("ro.product.device") == "grouper" || getprop ("ro.build.product") == "grouper"

the problem is, I'm 100% sure nexus 7 wi-fi is grouper. Some other roms, like cyanogenmod install OK, but I'd like to try something else.

So, what's the problem, and how can it be fixed?

1 Answer 1

2

Interestingly I had this exact same problem.

It seems to be an issue with the latest version of TWRP. I solved it by downgrading TWRP to 2.6.3.0 - I'm assuming there must be a bug with the 2.6.3.1 version.

That should work (as my scenario was the same: Nexus 7 (1), TWRP and the MIUI ROM).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .