24

To begin with, I've tried in futility to search everywhere else on the internet to fix this, so I'm asking here now.

I have a Nexus 4 running Android 4.4. Sometime within the past year, DONT started appearing as a word in my autocorrect options. IIRC, it began appearing immediately after an OS upgrade (I'm thinking the 4.3 release).

Screenshot:

enter image description here

I do not have DONT in any user dictionaries on the device. I have exhaustively searched all user-level language/dictionary settings and cannot find this anywhere. It's really annoying because it takes over the default correction of don't, so I just end up looking stupid.

(Here is my personal dictionary listing [one item redacted]):

enter image description here

If DONT were here it would be between Catan and Dropbox

Is there some other/hidden location where dictionary/replacement text gets stored? And/or does anybody have another suggestion for how to get this stupid word removed from my device?

  • 1
    What an interesting issue! You might need to completely restart your personal dictionary and start from scratch. Additionally, you might want to upgrade to a different keyboard. – Zlatty Jan 13 '14 at 20:23
  • 2
    If I were you I'd have redacted Catan too. Now the whole world knows what geeky board games you like! – Dan Hulme Jan 13 '14 at 23:55
  • 1
    Let's face it @DanHulme, I've posted on enough Stack sites to forego any facade of un-geekiness :) – eouw0o83hf Jan 14 '14 at 13:59
10

I fixed it! The trick was to clear the cache and data for Google Keyboard.

Settings => Apps => ALL* => Google Keyboard => {Clear Data, Clear Cache}

* Be sure to go to ALL instead of RUNNING. The instance under RUNNING will not give you the correct data clearing options.

  • 8
    Hey this isn't a fix as doesn't preserve existing dictionary data. – Android Quesito Jan 13 '14 at 23:39
  • 2
    It does really suck as a fix, but it accomplishes the primary goal of "get that annoying extra word out." Personally, I'd rather rebuild my small personal dictionary than have to deal with DONT popping up every time I want don't. – eouw0o83hf Jan 14 '14 at 14:01
  • Better use SwiftKey & it's AI & it's dictionary cloud sync. – Android Quesito Jan 14 '14 at 14:53
  • Sachin Shekhar: two points. Google Keyboard has dictionary cloud sync as of (I don't remember when, maybe after you made your comment), second... try typing an email address or web address into a text field (like, say, a Hangouts conversation) with Swiftkey. I dare you. I was all on board with Swiftkey until it kept turning stuff like "www.microsoft.com" into "Www. Microsoft. Com." with no option to override... – evilspoons Jul 4 '14 at 14:32
  • this answer didn't work for me. at first I thought it did, but it did not. I want to remove mispellings that are in the dictionary :( :( – Rudolf Olah Jul 6 '14 at 16:40
9

Long press on the word when you type it and see it above keyboard. You will be given an option to delete it from learned words. Android 4.3

  • I did try that; it would appear that it wasn't actually a learned word, but maybe just an artifact of some bad cached data? – eouw0o83hf Jan 15 '14 at 20:23
  • Works for me: Samsung Galaxy S III mini, Android 4.1.2, Samsung Keyboard – Jakub Narębski May 22 '14 at 10:29
  • 1
    doesn't work on android 4.4 – Rudolf Olah Jul 6 '14 at 16:40
  • 3
    On Android 4.3 and Samsung Galaxy Nexus this is not working at all. When I long-press incorrectly suggested word, all I see, are other suggested words. No sign of delete or edit option. – trejder Oct 14 '14 at 10:14
  • Worked on my Note 2 running 4.4. – jimchristie Jan 14 '15 at 2:41
3

This is a strange solution but it seemed to work (tested on Android 4.4):

  1. go to System Settings
  2. scroll to Accounts section
  3. click Google
  4. under Privacy section, click Search
  5. under Search & Now Cards section, click Accounts & privacy
  6. scroll all the way to the bottom and click Search engine storage
  7. click Clear now

Try typing one of the words you didn't want in your dictionary and it should not appear.

It seems like Google hasn't documented that their keyboard now uses suggestions from the personal/user dictionary, their standard dictionaries, and also from their Google Search and GMail suggestions.

I think SwiftKey only learns words from your email or texts when you explicitly allow it to. Otherwise it learns from your typing. Google's Keyboard should probably do that or at least make it clear exactly where the suggestions are coming from.

  • the SafeSearch Filter is also in the Search > Accounts & privacy menu, might be a good time to turn it on too! – Rudolf Olah Jul 6 '14 at 17:02
0

I just fixed it! I'm running a Galaxy Nexus phone with Android 4.3 and I had a similar problem. In addition to saving words like "thibk" and "tou" (go home, thumbs, you're drunk), it somehow ended up containing the word "THEYRE," much like OP's "DONT."

This drove me insane - how dare the Great Googly One tell me not to use an apostrophe? It's my right as an American citizen!

Anywho, I went to Settings > Apps > All > Google Keyboard and then uninstalled all of the updates to Google Keyboard, bringing me back to the stock factory settings. It didn't delete all of my texts, nor did it mess with my personal dictionary ("Mutha***kin'" is still right where it belongs). I'm also now running Textra instead of Swiftkey and I find it much cleaner and easier to use, but that's neither here nor there.

Anyway, good luck! DONT let them get you down, OP!

  • +1 Great Googly One. I have exactly the same environment, i.e. Galaxy Nexus with Android 4.3. I went to Settings > Apps > All > Google Keyboard and all I see is: Force stopd (does nothing), Disable, Clear data and Clear cache. Plus long list of permissions. How did you managed to uninstall all updates (or uninstall anything) to this system service? – trejder Oct 14 '14 at 10:18
0

I just worked out how to do this. If you open a text in messaging, then type the word that autocompletes, long hold, as Gil noted, and then select delete, it will then remove all instances in other software. This also means you don't have to clear all your other, correct, auto-completes.

I'm using 4.4 on a s4

0

I found out on my Samsung Note3 that I had to deselect the google voice guided (my translation is "Google Spraakgesturud ty.." After that I could hold and delete words from the dictonary.

-1

I had the same issue and found it a couple of months ago.

You should go to: Settings >> Language & input >> Personal dictionary.

Choose the language which the incorrect word was stored and then a list of all personal words will be there. Just choose it and then delete (or you can also edit, it's up to you).

This path was used for my Nexus 4 4.4.2 Kit Kat (the same of yours). Other brand's Android version may be quite different.

  • 5
    It would seem that the OP was already able to find their personal dictionary and that the offending word was not found therein. – ale Jan 13 '14 at 20:35
  • @AlE. is right, I've already tried this. – eouw0o83hf Jan 13 '14 at 21:08
  • THIS WORKED FOR ME ON STOCK Android! Removed just 1 word from personal dictionary (At least on Android 5.0.1) Get the feeling Samsung devices changed the functionality opting for an interface using the keyboard but why they didn't leave this perfectly workable Personal Dictionary interface intact I don't know – Coops Jan 21 '15 at 9:46

protected by Community Sep 9 '14 at 1:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.