0

I am an Android developer and I have been using my SGS2 for a while and I was accessing the debugging mode without any problem, until I broke my phone's screen. I found a repairer who replaced the screen with another. Since that day I cannot access my S2 neither on Debugging mode, nor on USB File Transfer mode.

How can I fix this?

EDIT

It still charges when connected to PC, but no feedback in my Win 7. I tried with other computers and getting the same things ...

  • 2
    Sounds like the "repairer" messed up something. Have you checked with him? – Izzy Jan 14 '14 at 11:55
  • i wanted to be sure before going back to him ! what has he messed up ? – mansoulx Jan 14 '14 at 12:07
  • Guess some "cables". I'm not in hardware, so I cannot be sure: but if it worked before, and all that has changed was some hardware, the culprit is most likely to look for there. Does it still charge when connected? Do you get any feedback on either your PC or the SGS itself when connecting the cable? Have you tried a different cable, and are there any differences then? No charge, no feedback, and no difference would make it pretty sure a messed-up "wiring". Even if charging works, he might have forgotten about the other two (data) pins, or accidentally losened something. – Izzy Jan 14 '14 at 13:22
  • Thank you @Izzy. I have edited the question to provide some more information for new comers. Please can you explain what you mean by : he might have forgotten about the other two (data) pins, or accidentally losened something – mansoulx Jan 14 '14 at 15:36
  • To replace the display, he needed to at least partially dis-assemble the device. I have no idea how it looks from the inside, but he could have accidentally losened some connections, or simply have forgotten to re-attach something. There are definitly some connections he had to replace (to make the touch-screen work). But that's rather an Android unspecific hardware issue. Why not just ask the one person who should be able to tell? We can only guess here. – Izzy Jan 14 '14 at 15:42
1

The description of the issue pretty clearly pointed to a hardware issue (the "repairer" having "messed up" / forgotten to re-attach some "connectors").

As reported back, this guess was correct: Taking the device back to him and have him check, he found the "missing link", repaired it, and the device is fully operational again now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.