3

This question already has an answer here:

I have a Galaxy Nexus with the stock firmware, it's a device that has been powered off for a long time. Currently I can't update any existing apps nor can I install new ones. I have tried with Chrome, Firefox Beta and Opera Mini, I also tried updating existing ones with no luck. Also there are apps that have updates available but Play Store doesn't offer the option to update (for example the version of Firefox is 16), others (actually just one) are listed as having available updates.

There are two different behaviors that occur.

When trying to install Chrome

The Google Play says that the app is not compatible with the device, i don't think is the case. The same happens with Firefox which is listed as a supported device in the mozilla page

When trying to update an app or install Opera Mini

When trying to update an app with updates available or installing Opera Mini my device is recognized as supported but after clicking install and accepting the permissions an error occur, it says:

Error retrieving information from server. [RPC:S-3]

I have already deleted the Google Account and recreated it (password works)

Android version is 4.1.2 build number JZO54K. No carrier and no SIM, connected over a working wifi (I can surf the net with firefox)

Any ideas?

marked as duplicate by Flow Mar 4 '14 at 9:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5

Did you try clearing the app-data of play store? If not, try clearing the app-data, and/or any updates installed by play store, and allow it to install a Play Store update again (it will do this automatically), and then try using Google Play Store.

  • I suppose this should do the trick – Kmelkon Jan 15 '14 at 6:16
  • As said by Izzy following those steps did solve the problem combined them with what you said of removing updates to the Google Play Store, I didn't test them separately so I don't know if both steps are actually needed. – Javier Mr Jan 17 '14 at 11:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.