1

I'm trying to connect to my home's wireless router with my new LG G2 (running version 4.2.2) and it keeps saying "Obtaining IP address..." for three minutes, then momentarily saying "Saved, secured", before cycling through all over again. It does this about 5 times and then eventually stops trying and says "Avoided poor Internet connection".

It seems that the problem is only affecting my Android device. My laptop can connect; my mother's and girlfriend's iPhones can both connect; and this is the second Android device I've had with this connection issue (my old Droid 4 had it too).

I can't figure out what the problem could be. I've tried changing the broadcast channels on the router with no luck, and I'm too worried to mess around with the network settings much more, for fear of messing up the network for more devices.

On top of this, with the recent phone upgrade and data transfer, I'm at 90% of my monthly data usage, with half a month yet to go. :[

What can I do to connect to the wireless, short of getting a new phone or new router?

[EDIT 1] OK. So now I've tried using my desktop as a mobile hotspot, and this is still not working. Perhaps the most troubling part is that it isn't working even when I bypass the router altogether, and plug the computer directly into the modem. It even failed both with and without encryption.

[EDIT 2] Here is a screenshot of the Advanced Wi-Fi settings, as requested.

advanced wi-fi
Click image for larger variant

  • I have tried this and just about everything but my WiFi still is not connecting, it says saved and secured and when I press connect it connects for about 2 seconds, yes, I have tried 're entering my WiFi password but even that won't wont – user61335 May 23 '14 at 14:17
  • If your device rooted? + Try this... disable WiFi connection, put your phone in "Airplane mode" and then turn on WiFi again, and check if it results the same problem. – FiN Sep 3 '15 at 12:55
1

Goto Settings --> Wifi-->(press menu) Advanced--> uncheck "Avoid Poor Connections" checkbox.
Then Click on network Available. Now it will connect(or else click forget and re-enter your password.

  • Thanks for your reply, but this option isn't listed anywhere in the menu. The only "advanced" options are (1) Keep Wi-Fi on during sleep [always] (2) Wi-Fi signal weak [unchecked] (3) Internet unavailable [unchecked] (4) Wi-Fi (battery) optimization [checked] (5) Manage networks – Patch Jan 15 '14 at 4:57
  • I was on the Advanced menu. – Patch Jan 15 '14 at 5:02
  • Pls mention device and OS version. – Akhil Jan 15 '14 at 5:16
  • I thought LG G2 with Android 4.2.2 was enough. The software version is VS98012B, if that helps. – Patch Jan 15 '14 at 5:19
  • Could you please post a screen shot of Advanced Settings menu – Akhil Jan 15 '14 at 5:36

protected by Community May 23 '14 at 19:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.