2

here's my problem : in normal situation my Internet only works with browser (firefox) and not any other app like markets or Duolingo . But , when I use DroidVPN it starts to work with other apps as well . I suspect Google setting and Google market . I have uninstalled both of them because of some problems that they have . recently when I reinstalled them , this problem appeared . ( But I'm not sure , cause I think a while after installation it was working . ) by the way I am using my home wireless . my background data is on . I need my Internet back without any VPN app and I DON'T want any factory reset or any kind of reset and those stuff . I've read all other similar question and answers . non helps ! can you help me ? PLEASE ? any help would be appreciated !
p.s. I'm using the wireless with my laptop to . and every thing is ok with it .

10
  • I'd suggest trying on a different wireless network. This sounds more likely to be a problem with your network than your phone.
    – Dan Hulme
    Commented Jan 15, 2014 at 13:38
  • Thank you for your comment . well , I use the wireless with my laptop too . and I don't have such a problem with it . so , do you still think that it is a problem with my wireless network ? I really need to fix it . thanks
    – Babak
    Commented Jan 15, 2014 at 14:32
  • That's an interesting data point. Could you edit your question to add that information, and also let us know what internet apps work on your laptop?
    – Dan Hulme
    Commented Jan 15, 2014 at 14:35
  • Could you check your WiFi AP settings whether there's a proxy defined (in its advanced settings)? If I remember correctly, Firefox is one of the few apps ignoring global proxy settings, which might be the reason it works. And with the VPN not established, the (then wrong) proxy might prevent all other apps from accessing the network.
    – Izzy
    Commented Jan 15, 2014 at 15:19
  • @DanHulme on laptop every thing works fine with the Internet .
    – Babak
    Commented Jan 15, 2014 at 20:49

1 Answer 1

1

I just had this issue on my Nexus 10 running Android 5.1.1.

I could not connect to the internet via my Wifi access point (AP) but I could connect to my VPN (Private Internet Access) and then connect to the internet. This only affected one device, all my other devices (laptops, phones, other wifi gadgets) had no issues connecting to the same AP.

The issue I found had to do with the DNS Leak Protection from Private Internet Access (PIA). The solution was to set a static IP address and DNS settings.

  1. Disconnect form your VPN
  2. Long press on your wifi network in the wifi settings
  3. Check Advanced Options
  4. Add your IP address and gateway (the IP address of your router)
  5. I added 209.222.18.222 as DNS 1 and 209.222.18.218 as DNS 2. These are the PIA DNS settings.
  6. Save those settings and test your connection

This fixed the issue on my device. Curiously this issue only affected my Wifi AP, when I connected to another access point I did not set have to set a static route.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .