I am trying to get the fastboot driver for Sony Xperia ZR (dogo) for Windows 7 x64.

I found a page with instructions which pointed me to a Sony site where you can download a android_winusb.inf file which one is supposed to copy over the one in the Android SDK folder under extras\google\usb_driver\.

Then, I put the phone into fastboot mode by

  1. Powering it off
  2. Pushing the Volume Up button while connecting the phone via USB to the PC.
  3. The light turns blue and in the Windows Device Manager, I can see a new S1Boot Fastboot entry under Other devices.

After right-clicking on that entry and selecting Update Driver Software..., then Browse my computer for driver software, I pointed to the Android SDK folder where I previously put the android_winusb.inf file (see above).

Unfortunately after clicking Next, there is a message Windows was unable to install your S1Boot Fastboot and Windows could not find driver software for your device.

On this thread, I found a link to a thread on XDA Developers where one can download a "fastboot package" and "32/64bit drivers", but I am hesitant because these are EXE files from an unknown source and the thread's title suggests this is for Xperia Arc, not ZR.

Are there any "official" drivers for my phone?


I also found a great Sony webpage listing "All Android downloads" which has white papers, source code and drivers for all(?) devices, except the drivers for the ZR are missing.


I have seen this comment to a question concerning fastboot drivers and USB device IDs, so I tried to replace device IDs for SingleAdbInterface, CompositeAdbInterface and SingleBootLoaderInterface (sequentially, not all at once) with the one which I got from the Device Manager, which is USB\VID_0FCE&PID_0DDE&REV_0100. Unfortunately this didn't make any difference, the drivers are still not recognised.

3 Answers 3


While playing around with the INF files, I found that the one supplied by Sony actually does work, you only need to "force" Windows to use it for your device. I am not sure if that has anything to do with the unsigned nature of the driver or that Windows cannot verify that the driver is compatible (see below), but it simply doesn't seem to accept the driver with Sony's INF automatically.

I order to install the driver, I did the following:

  1. In the Device Manager, right-click on the S1Boot Fastboot entry and select Update Driver Software, then Browse my computer for driver software and Let me pick from a list of device drivers on my computer.
  2. Select Show All Devices, then Next.
  3. Click Have Disk... and then Browse... to the android-sdk\extras\google\usb_driver directory.
  4. Then the Model list is populated with three entries, select the one called Android Bootloader Interface and click Next.
  5. Click Yes on the Update Driver Warning message mentioning that Windows cannot verify compatibility of the driver with the device.
  6. Click Install this driver software anyway on the Windows Security message saying that Windows can't verify the publisher of this driver software.

After that, I was able to run fastboot commands on my device (I only tried devices and reboot so far).

On a side note, I found it interesting that you actually don't need any specific driver binaries such as DLLs from Sony and that the drivers supplied with the Android SDK seem to be sufficient, except for the INF entries with the correct device IDs.

  • Unfortunately this didn't work for me. After browsing to the right spot and clicking Next I am not prompted anything. Windows just says that it cannot find any driver there. Any help?
    – Dakatine
    Commented Jun 24, 2014 at 22:53
  • @Dakatine: Have you copied the INF file from Sony into that directory?
    – FriendFX
    Commented Jun 25, 2014 at 2:10
  • Yes, indeed I have. The other solution worked for me (that is, installing the drivers by using a third party "homebrew" software). This sounds quite odd and irrational, but here it is. :)
    – Dakatine
    Commented Jun 25, 2014 at 10:27
  • @Dakatine: Glad you found a solution. The next thing I would have suggested is comparing the device IDs in the INF file with the one you see in the device manager... anyway, do you have a link to this "homebrew" software for others?
    – FriendFX
    Commented Jun 25, 2014 at 12:37
  • Yes, I just used the link I found in the "other solution" down here. Sorry if that was unclear in the comment above and thanks for your feedback.
    – Dakatine
    Commented Jun 25, 2014 at 15:15

I had the same trouble with my Xperia Z just 2 days ago, but the I found the Flashtool-drivers package. This included drivers for several Xperia devices, and I think for ZR too.

The download can be found here, and the post that lead me there is this one.

I trusted this package since it's by a recognized member of XDA, DooMLoRD.


I created a adb and fastboot drivers installer tool, so people don't have to face issues like this

Here is the link to that tool: https://github.com/fawazahmed0/Latest-adb-fastboot-installer-for-windows

You will just have to connect the phone with usb debugging mode enabled and then run the tool Hopefully that should fix the problem for you

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .