0

I cannot see a delete function on my Gmail account for my inbox.

I have a Galaxy smartphone.

4

This post should (or might) help: GMail's delete button is not gone, it's just hiding.

Edit: As per the URL, follow the steps below:

  • Hit the menu button, and go to settings. Then, go to general settings. You should see the option below at the top of the list - Archive & delete actions. Right now, it should be set to "Show archive only"
  • Tap it, and you get three options - Archive only, Delete only, and Archive & Delete. The third option gets rid of the 'Move to Folder' action. Choose the one you want (probably the second or third), and you're set to go - your little trash icon will return.

Note: If you still want to swipe to delete, you must select 'delete only' from the actions menu above.

0