0

My SGS2 is dropping it's network connection multiple times a day without any notification. The signal bars disappear and it just says NO SERVICE/VODAFONE NZ. No data, no 3G, no 2G, nothing...

I was previously on Gingerbread 2.3.6 and was hoping that CyanogenMod would fix the issue. I flashed it to CM 10.2 but the same issue remains. This makes me think it is a hardware issue and not a software issue, however it did not wipe my internal SD card - could there be settings in there that are causing this?

It seems to really love the ground, so I'm wondering if it has just been dropped one to many times and cracked some solder connections somewhere internally?

UDPATE

Installed the GetRIL tool and it said the stock RIL was unknown.

I installed the first RIL on there. It said that it would backup the stock RIL. The one I installed didn't work so I installed another one. That didn't work either. So I tried to restore the stock RIL but then I read in the FAQ it only restores the last one installed.

So it restored the broken RIL. And now I have no network and can't figure out how to get the stock one back. Yay.

Here's the stock details:

RIL: Unknown - 163ecafa01912637fe344ec1f8264d70
Baseband: I9100XXKE7

Anyone know how I can get the stock RIL back?

As an aside: the battery lasts sooooo long without the carrier network

UPDATE

Reflashed with CyanogenMod so I got my stock RIL back. Still monitoring the network drops.

  • 1
    I assume the phone is rooted. Search for baseband applicable to your device model, country etc. Try downloading an app called GetRIL, which will show you the list of applicable RIL which matches the baseband applicable to your device. This fixed it for me based on my searches on xda-developers. Hope it fixes for you too. – shahkalpesh Jan 17 '14 at 7:23
  • Yep, installed GetRIL then I broke it by installing too many RILs (only backs up last installed RIL) so I lost the stock RIL. :( Updated question. – hamstar Jan 21 '14 at 4:43
  • I think GetRIL shows you compatible RILs, from which you can choose. Also, you can search for RIL compatible for your phone, country etc. There used to be a list where you could see baseband version applicable to your phone, country etc. – shahkalpesh Jan 21 '14 at 7:13
  • Yea it said my ~~baseband~~ RIL was unknown, but had a recommended one which I tried - if I had hit restore straight after seeing that one didn't work I would be fine. Luckily I had sent the report to the GetRIL developer so I know the details for my stock RIL but just have no idea how to get my stock RIL back. – hamstar Jan 23 '14 at 0:12
  • Created another question for this specific issue: android.stackexchange.com/questions/61768/manually-replace-ril – hamstar Jan 23 '14 at 0:16
1

I have had the exact same problem. CyanogenMod SGS2, baseband I9100XXKE7, checksum 163ecafa01912637fe344ec1f8264d70. The only difference is I'm with Optus in Australia.

After extensive research, the solution I found was simply a matter of identifying an appropriate Modem+RIL (Radio Interface Layer) to install. I'm still looking for an appropriate one for me, although I9100XXLS9 has stopped the dropouts, it won't let me make calls.

Unfortunately it seems the best Modem+RIL combo is very dependent on your carrier+phone combo. I found a discussion about various RILs to use for SGS2 in New Zealand. You may find what you're looking for there. I've seen people discussing I9100JJLS2, I9100XXLS8 and I9100PBVLP7 as good modems.

If you look at your other question (How to manually replace ones RIL) you'll see it's pretty quick and easy to flip around between different RILs when you know what you're doing. Give them a try and see how you go.

  • After a day of testing, I've discovered I can't make calls on I9100XXLS9, although it's fixed my other problems. Sorry if that steered you wrong at all, but the rest of my answer should be good. I'll let you know if I find out more. – Excrubulent Jan 29 '14 at 15:03
1

This is a warning only for S2 i9100 owners, reading this question after seeing carrier drop in their phone. This thread suggests using GetRil. As far as I understand carrier drop issue, RIL depends on the firmware installed. What is to be changed is the modem/baseband. Now, before you try that out,

  1. *#1234# in your s2 i9100. If the response contains "Phone: Unknown", there is hardware fault and chip RFIC(U100) will need to be replaced as in this link
  2. Other wise, your phone don't have hardware fault. Feel easy. Before you proceed with rest of steps, I suggest, you take it to Samsung Service and they will easily fix it for you. The issue is only software now and could be fixed easily by Samsung. If you try too many things, it could end up affecting hardware as in Step(1) and then that will need chip level servicing which might not be performed by Samsung service in your locality.
  3. Ok. You are willing to take the risk. Now check your baseband version in About->device. In my case, carrier drop was accompanied with baseband unknown. If your baseband is known - a tip, which I haven't tried out is to, first flash the stock firmware from sammobile.com and try flashing different modems/baseband. Think of modems/baseband as like PC drivers. Don't change RIL. It comes with firmware. Also before proceeding with step(3), take a backup of your EFS folder( with apps mentioned in step(5) ) if your baseband is known.
  4. If your baseband is unknown, check if your IMEI is unknown/null.
  5. The baseband/IMEI unknown is result of a corrupted EFS folder. There are mobile apps like GSII repair, kTool( for rooted phones) in play store which will restore your EFS folder. Also there is desktop based EFS Professional ( for rooted phones ) which again will restore EFS folder. They work some times. Some times they don't. They all depend on a good EFS folder backup. If you have an EFS backup from a good phone of exact model/firmware, you can try restoring it.
  6. If Step(5) didn't help, there is also a SRS remote unlock client which has steps for first restoring baseband and then flashing IMEI. You need some credits to use the software though.

Suggestion: You might feel you are geek and could fix this. You might feel like this will be great experience fixing this phone. I felt the same. But unless you are very sure of what you do, please proceed to Samsung service.

0

I would try to flash the device to stock rom first. This should install the updated drivers. Latest version of SGS2 official rom is 4.1.2 .

http://xperiahtcrootingrom.com/stock-rom-for-galaxy-s2-i9100-official-firmware-variants/

  • 2
    I doubt that would be any help. OP was on stock before, and had the very same issues. The approach recommended by shahkalpesh in his comment sounds much more promising, as problems in the baseband/RIL are the most likely case with the problem existing on different ROMs. – Izzy Jan 17 '14 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.