0

Got my S3 Mini with CM11 stuck at boot after adding external display simulation in Developer Settings. Just after that UI froze and I had to reboot. After that it freezes on "Android is upgrading" popup and the progress circle isn't even running.

I tried going to Safe Mode but the only difference is that the progress circle is running all the time but nothing happens for another hour.

Logcat says something like this:

I/DisplayManagerService( 2137): Display device added: DisplayDeviceInfo{"Nakładka nr 1": 720 x 480, 60.000004 fps, density 160, 160.0 x 160.0 dpi, touch NONE, rotation 0, type OVERLAY, FLAG_SECURE, FLAG_PRESENTATION}
E/gralloc ( 1671): gralloc_alloc: gralloc_alloc_framebuffer (google) failed, Out of memory
E/FramebufferNativeWindow( 1671): fb buffer 0 allocation failed w=480, h=800, err=Out of memory

Is there any way to remove the additional display without having to do data wipe? I have full access to ADB and recovery. Just this one thing stops Android to boot further.

2 Answers 2

0

You can try wiping cache and dalvik before entering the safe mode. A similar problem is addressed on an XDA thread here.

If the above doesn't work, you can restore the previous backup (hopefully a NAndroid one). If that doesn't work, you can try flashing CM again. Finally, if none of the above works, you can do a full data wipe and factory reset and flash + restore again.

Yet another approach is manually editing the developer options database via ADB as discussed here.

adb shell
sqlite3 /data/data/com.android.providers.settings/databases/settings.db
delete from global where name="overlay_display_devices";
reboot

If the above doesn't work, then as said in above XDA thread, delete the developer settings manually as follows (all system specific settings will be reset), first mount /data in recovery:

adb shell
cd /data/data/com.android.providers.settings/databases/
delete settings.db
reboot 

If nothing works, the problem could be something different than the secondary display.

1
  • 1
    OMG this is great! Since noone answered I've done full wipe soon after the question. I was looking fo exactly such a solution (modyfying DB) which probably works. I'll reproduce the error and report later. Thank you! :)
    – marines
    Feb 26, 2014 at 19:20
0

Use the following command to disable the display overlay via ADB

adb shell settings put global overlay_display_devices null
1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 25, 2023 at 7:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .