3

I am trying to solve the problem of having an empty list of devices when running adb devices. Why is it not appearing?

I have tried the following to no avail:

  • Installed Kies and ran Tools > Install driver; then restarted
  • Turned off the Mac OS X firewall in
  • run sudo adb devices instead of just adb devices
  • Read the user manual from Samsung, which simply refers me to use Kies
  • Attach S4 to a different macbook in case the USB input is faulty
  • Try both different USB inputs in my Macbook Pro

The output I see after doing a fresh restart and plugging in the S4:

./adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached 

(with nothing more shown underneath)

Also, even after installing the drivers using Kies, the device does not appear there.

I am running OS X 10.9 on a Macbook Pro. The phone lights up and does start to charge when it is plugged in to any of the 2 USB ports on my Macbook.

What else can I try to have my brand new S4 appear in this device list?

EDIT It seems according to this thread (http://forums.androidcentral.com/samsung-galaxy-s4/282817-pc-cant-detect-galaxy-s4.html) that it may just be a faulty cable. I'm currently using the cable that came with the S4. I'll try other cables.

4

Answer: I was using the cable that Samsung provided with the phone

Solution: Go get a USB<>MiniUSB cable that was provided with a digital SLR a few years back and use that instead. The S4 now appears in the adb output and in Kies just fine.

<sarcasm>Thankyou Samsung</sarcasm>

  • same issue in my case if you solved this please msg here – ravi Apr 8 '16 at 8:31
  • Same issue and same resolution for a brand new Samsung Galaxy S7 (in addition to enabling Developer Options and USB Debugging). – Mattio Sep 2 '16 at 14:09
4

If using a better cable doesn't work be sure to enable the USB debugging feature under Developer options > Debugging

1

This worked for me: try unlock screen after phone is connected. Screen lock seems to block access to the device from USB as well it seems.

0

Enable USB Debugging mode solve the problem!

For those who don't know how to enable it (it's very hidden on Android 4.3 onward), see this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.