6

This always happens to me. Someone tells me to access some folder on Android (in this case /sdcard/Android/data/com.android.lmt/) and I can't find it. I'm using the "File Manager" app and asking it to show hidden files and folders but I still can't find the folder. This happens a lot.

Screenshot
Screenshot (click image for larger variant)

  • 1
    Why not try other apps like Solid Explorer, ES File Explorer or Explorer? They have options to show hidden files. – k1chy Jan 22 '14 at 9:40
  • @k1chy I think you can post that as an answer.:) – geffchang Jan 22 '14 at 9:46
  • 1
    What folder you don't find? sdcard? Android? data? com.android.lmt? You also need root to browse /sdcard/Android/data. – Matthieu Harlé Jan 22 '14 at 11:38
13

First, you should be aware of the difference between "hidden folders" and "inaccessible folders":

  • hidden folders: names start with a dot, e.g. /sdcard/.android_secure. These files you can see enabling the "hidden files" option in file explorers.
  • inaccessible folders: folders you won't see due to lacking permissions, e.g. those in /data. To protect your apps' data, those folders belong to the corresponding application, and are only accessible by the app (in the context of ; please see the tag's wiki for closer information on those). To make those visible, you need root access on your device, and a file explorer supporting that (e.g. ES File Explorer)

So while you were asking for the former ("hidden folders"), you were really referring to the latter: data/com.android.lmt/ belongs to the LMT launcher.

  • the weird thing is that I have LMT installed but as you can see on the screenshot, the folder isn't showing up where it was supposed to be, t least where the XDA thread of the app says it should be. I've edited my question so you can see the screenshot – Thiago Jan 24 '14 at 23:35
  • I bet the app is storing its data on /data/com.android.lmt, i.e. on internal storage. Only few app do so exclusively on SDCard, which is mostly used for "larger amounts of data" only. So the problem is not my description being wrong, but the folder not being there. – Izzy Jan 25 '14 at 1:02
4

Why not try other apps like Solid Explorer, ES File Explorer or Explorer?

They have options to show hidden files.

1

You should try Astro File Manager.

You can't find your hidden folders or files?

ASTRO FM is very robust and due to user requests, ASTRO added the ability to override "global settings" with "directory specific settings".

First, go to Look and Feel under Preferences (menu, more, preferences, look and feel). Click on Show Hidden Files. If this doesn't work, it is because the directory that you have created some directory specific settings on the directory you are in.

You can either:

a) go back to Look & Feel and click Reset Directories which will wipe out any directory specific settings, or

b) go to the directory your hidden files are in (probably your SD Card directory) and click View, Set Directory Options, and click Show Hidden Files in that directory.

Taken from here

  • I can confirm that the following worked just now to show my hidden ".Temp" folder on the internal sdcard: Settings icon -> Appearance -> Show hidden files -> check. Then, click "Clear" next to "Clear custom directory settings". Then, went back twice and the hidden ".Temp" folder was shown along with other hidden folders. – Someone Somewhere Jan 25 '16 at 14:51

protected by beeshyams Nov 2 '18 at 16:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.