8

When I receive an incoming call the phone doesn't show the dialer/answer screen. If the screen is off already the phone rings but the screen does not come on. If the screen is already on and already dim the brightness will come back up, but the screen doesn't change. So if I was already on the home screen it just stays there. I cannot answer a call unless I use my Bluetooth headset to do so. It does this with or without the headset connected. If the headset isn't connected I cannon answer the phone.

If I hit the phone icon it comes up to the screen asking me if I want to return to the call in progress. I also noticed if I make a call it never comes up to the in call screen, so there is no way to mute, go to speaker phone, put the call on hold, or more importantly end the call.

This started shortly after upgrading to 4.4 from 4.3.

Android 4.4 Nexus 4

2
  • I disabled the Dialer app, cleared the cache, and the data.
  • Rebooted the phone and enabled the Dialer app.

Now all seems to be working well.

  • The phone app or the dialer app?..coz i can't disable the phone app..only dialer i can disable.. – Lucky May 28 '15 at 17:46
  • 1
    @Lucky The dialer app – Move More Comments Link To Top May 28 '15 at 18:00
1

I just have had an issue that matches the OP description: on incoming calls the screen remained blank.

I am having it on Android 5 - Lollipop, but should be worth a try on a KitKat phone.

Solution:

  1. Open "Google Dialer" (a.k.a. "Phone")
  2. Open the : menu.
  3. Select "Settings"
  4. Choose "Call settings"
  5. Choose "Phone account settings"
  6. Tick the "Receive incoming calls" checkbox

Cause: The option was turned off when the phone was in the "battery saving mode" due to low battery charge. After recharging the battery the option was not restored automatically.

Device details: Nexus 5, Android version 5.0.1-Lollipop.

0
  1. download dialer app.
  2. disable default dialer, clear app data and cache
  3. restart phone (notice there is no dialer app)
  4. install downloaded call dialer app.

Done. Works 100%. Tried it on my phone

p.s., search for "nexus 4 call dialer app"

0

Go to Settings>Sounds & notification>App Notification then unblock the Dialler App then everything will be normal again.

0

I had this problem after doing a factory reset and reinstalling apps on 7.1.2 (Lineage 14.1). I couldn't answer incoming calls and outgoing calls wouldn't show the call in progress. The notification settings were fine. Clearing cache and booting in safe mode did not help.

The problem was the Phone app was not set to be the default application for phone calls. Not sure why because there were no other apps installed that can handle the calling intents.

To fix, go to Settings->Apps-> ⚙ ->Default Apps->Phone app. If it doesn't say Phone immediately under Phone app, then tap and choose the Phone app.

Not the answer you're looking for? Browse other questions tagged or ask your own question.