1

I want to transfer files to my Nexus 4 using the Mac Terminal.

I tried to use the adb shell with adb push, but because I'm not root I'm not allowed to push to the sdcard.

Is there any way to mount the device as a regular drive or to use adb push without root access?

6
  • You should be able to use adb push even without root. What's the message you get when trying to adb push ~/file /sdcard/file?
    – dotVezz
    Jan 24, 2014 at 21:23
  • As I wrote below it's "error: device not found"
    – skappler
    Jan 25, 2014 at 21:52
  • What do you get if you try to run adb devices and adb shell?
    – dotVezz
    Jan 25, 2014 at 22:51
  • Everything works fine. I see my device and I can log in to the shell. All normal commands like cd, ls, pwd etc work. Only push and pull throw this error
    – skappler
    Jan 26, 2014 at 9:33
  • And just to confirm, trying to do cd /sdcard/ works? (I know I'm being tedious, I just want to make sure nothing has been overlooked).
    – dotVezz
    Jan 26, 2014 at 23:33

1 Answer 1

0

You can't push to the sdcard's root, but you can push in any folder found in it, except /sdcard/Android/data.

5
  • I tried this but I got "error: device not found"
    – skappler
    Jan 24, 2014 at 8:13
  • @user1839433: Have you enabled USB debugging? Jan 24, 2014 at 8:17
  • Yes I enablded debugging, adb devices shows my device and I can see all data on my phone using adb shell and ls/cd/... I only can't push and pull
    – skappler
    Jan 24, 2014 at 10:49
  • What do you mean when you say "You can't push to the sdcard's root"? Because you can push to /sdcard/ no problem.
    – dotVezz
    Jan 24, 2014 at 21:23
  • @dotVezz: Because I heard here and there that we can't. I can, but I'm on 4.1.2 and rooted, so I assume we can't and I tell a solution that I'm sure would work under normals circumstances. Anyway, It seems he has another problem... Jan 24, 2014 at 21:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .