5

I'm on Windows 7 and have developer options including USB Debugging enabled. I have opened Kies and it recognizes the S4. However when I try adb devices, nothing to be found. It works perfectly fine with my Nexus 10.

I've also tried adb kill-server, adb start-server and then adb devices to no avail.

Anyone else have this issue?

6
  • Are the proper (ADB) drivers for the S4 installed on your Windows-7 machine?
    – Izzy
    Jan 26, 2014 at 13:00
  • Close Samsung Kies and make sure you have the right drivers (adb/fastboot) for your phone. IIRC, Kies has to be closed to use adb (never used a Samsung device).
    – k1chy
    Jan 26, 2014 at 13:53
  • Izzy, pretty sure. KIES and windows explorer recognize it. @K1chy, how do I make sure they are on my s4?
    – Eric H.
    Jan 27, 2014 at 0:56
  • @EricH. the drivers are for windows not on the phone. Most likely you do not have adb driver for your phone installed on Windows. Try reinstalling samsung drivers. If the problem persists, you may try installing adb driver from Universal naked driver from XDA.
    – k1chy
    Jan 27, 2014 at 3:06
  • Make sure you are using the right edition of Samsung Kies. For me, I also have a Samsung S4, and the proper version is Samsung Kies 3. (If you install the earlier version, it will report that it does not work.) However, "Samsung S4" is actually a marketing term, the underlying device models can differ depending on country and geographical (market) location.
    – rwong
    Sep 26, 2014 at 1:02

3 Answers 3

7

Re-install these official Samsung drivers.

  1. Uninstall current drivers by going into Device Manager. Make sure to check off the delete drivers option if given.
  2. Reboot.
  3. Reinstall the given drivers above without connecting the Galaxy S4
  4. Reboot.
  5. Go ahead and connect phone and verify that in device manager Samsung ADB Device or equivalent is shown.
  6. If it shows an exclamation mark on it or other problem, then in device manager right click on the driver, update, let me choose from a list and choose the correct android adb driver.
2
  • Thanks for the help. I just re-installed the drivers from KIES with the device plugged in (Tools >> Reinstall Device Driver). It then showed up unauthorized. So while plugged in, I changed toggled the USB Debugging option in Developer OPtions on the phone. All set now.
    – Eric H.
    Feb 2, 2014 at 2:49
  • Those 2 reboots are ridiculous, just download and install driver, then approve PC for debugging on the phone when asks. All while plugged in.
    – TWiStErRob
    Dec 20, 2014 at 11:20
6

The fix for me was using a different micro-usb cable. No software change, no drivers to update, just the usb cable. Apparently they aren't all created equal.

3
  • This was my solution! Oddly enough my phone was recognized the first few times I plugged in with the first cable, then stopped working when I updated the drivers. Changing the cable worked.
    – Rachael
    Aug 27, 2015 at 23:31
  • Same for me here! Really strange!!!
    – JohnyTex
    Sep 25, 2015 at 14:22
  • Also changed the cable and it is working now
    – Chris
    May 12, 2016 at 9:02
1

Changing the USB cable worked for me. I was using a cheapy old one that was laying around. When I replaced it with a newer one that I had, adb devices showed my Samsung Note 4 easily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .