Someone put CyanogenMod on my T-Mobile Galaxy S4. So I tried to unroot and return to the original by watching this Youtube video and using this method.This is what I have gotten from the phone:

Odin Mode
Product Name: SGH: M919
Current Binary: Custom
System Status: Custom
Knox Kernel Lock: 0X0
Knox Warranty Void: 0X1
Write protection: Enable
eMMC Bust: Mode: Enable
Start [224, 1440]                                           in red
SW REV. CHECK FAIL : fused : 4, Binary: 1 in red.

On the PC screen, in red, it says Fail!

In the message box, the last line read: All threads completed: (succeed 0 / failed 1).

Now I tried to reboot the phone, I got the same Odin Mode thing plus: CSB-CONFIG-LSB: 0X30 minus the two lines in red.

In the middle of the screen, a phone, a yellow triangle with an ! mark in the center, a PC screen.

Below says: "Firmware upgrade encountered an issue. please select recovery mode in Kies & try again."

I have no phone now. I know I didnt reset binary flash. So people told me to format and reinstall the OS. Please help me to go back to stock version.

  • 2
    Have you tried flashing your phone with the latest ROM (for your country and carrier) via Odin Download Mode? Since you have already tripped Knox (Knox Warranty Void = 1), you can't flash pre-4.3 ROMs. – geffchang Jan 27 '14 at 9:47

There are 2 ways:

  • Get the stock ROM which works with root from sammobile.com. Make sure that Kies isn't running. Then, flash the ROM with Odin, or,

  • Unroot using the custom recovery by downloading a completely stock normal ROM from sammobile which should get rid of root.

|improve this answer|||||
  • Is the OP supposed to follow these two steps? Or are they choices for the OP? AFAIK, if you flash a stock ROM with Odin, you immediately lose root. So, there is no need to unroot it (step 2). – geffchang Jan 28 '14 at 3:28
  • Do either. One will keep root one will remob – user51878 Jan 28 '14 at 13:40
  • Please edit your post to include that information. :) – geffchang Jan 28 '14 at 13:44

Knox warranty void: 0x1

You won't be able to flash a Knox enabled firmware anymore, but you can flash other firmware. Go to sammobile, search your firmware and flash it with Odin. You can also find the flashing tutorial from sammobile itself.

Remember: do not downgrade. This will damage your EFS folder.

|improve this answer|||||

Go here SamMobile Samsung GT-i9500

Download the one specified for your country

Boot to Download Mode, Flash using Odin

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.