A month ago I got a Nexus 5. It's running Android 4.4.2 (kernel:3.4.0-gadb2201). I noticed after using it for a while that it constantly keeps forgetting all saved wifi passwords after a restart. In the beginning I thought it might have something to do with my router, but the device also forgot the password of my university's wifi network, so that can't be the problem. Before obtaining this device, I had a Samsung Galaxy Nexus running Android 4.3 which never had this issue. That's why I have a feeling the issue is specific to Android 4.4.2.

Google was my first stop to try to find a solution, but it seems that I'm one of a few people facing this problem generally, and none has it with their Nexus 5. It's not a major issue because I can mitigate it by not restarting my device, but rather an annoying tiny inconvenience I'd like to have fixed.

Does anyone have an idea why this is happening? Is there a solution for it?

  • First thought is that you have backed up to Google and the backup is blank on their side, so when it synchs on boot it is deleting them.
    – RossC
    Jan 27, 2014 at 14:13
  • @RossC I currently have everything backed up to Google. Is there a way to make them reset their backup? I just disabled and re-enabled Google backup from Settings but to no avail.
    – Maher4Ever
    Jan 27, 2014 at 14:33
  • Short of a factory reset I'm not sure. I wouldn't go down that road first to be honest. That's just a thought on what could be causing it. WiFi fixer on the Play Store claims to fix this, but I haven't tested it nor can I vouch for it. play.google.com/store/apps/details?id=org.wahtod.wififixer Have you rooted the device and installed any custom firmware? I've not had this on Nexus 5 or any custom KitKat ROMs myself.
    – RossC
    Jan 27, 2014 at 14:50
  • This article points to the file that may be at fault has has a potential fix, but I'm wary of it bricking the device: georgecm.hubpages.com/hub/… It involves modifying data in bcm_supp.conf or wpa_suppliciant.conf files, which may have other roll on impacts.
    – RossC
    Jan 27, 2014 at 14:51
  • 2
    @Maher4Ever: FWIW, you were correct in that disabling and reenabling Google backup is exactly how you would reset the data Google backs up. From Android Developer Support: "...users can disable data backup functionality through the Android system's privacy settings. When a user disables backup, Android Backup Service deletes all saved backup data. A user can re-enable backup on the device, but Android Backup Service will not restore any previously deleted data."
    – Mr. Buster
    Jan 27, 2014 at 23:11

6 Answers 6


I have a Note 3 with Android 4.4.2 and I had the same issue. After disabling Google backup, everything is fine now. I couldn't retrieve my old backed up wifi networks, though.

  • That works for me on my Nexus 4, as well... but I'm not willing to run without google backup forever.
    – Flimzy
    Oct 2, 2014 at 23:01
  • 1
    An anonymous user edited in the following comment "1. Switch off backup 2. Go into Wi-Fi settings, delete (erase) the one you have problem with. 3. Re-enable backup 4. Only the, from scratch, enter the password and save the WiFi."
    – Compro01
    Oct 5, 2014 at 2:56

I'd do something different instead...
Since your problem is that your device does not store WiFi passwords (or this seems to be the real problem) I'd suggest you to go into /data/misc/wifi/ and find the *wpa_supplicant.conf file. In this file the device stores every WiFi entry.
Open it and see if there are duplicates: when you enter a password more than once this file creates more than one voice, resulting in multiple entries for the same network.
If this is the case then it's normal that the device asks you for the password again (because in case of entries conflicts it doesn't know which one to use).
My advice is to delete all the duplicates or all the entries if you feel like (do NOT delete the file, I'm not sure that the device will recreate it).
Happened to me with my Nexus 4 and doing so solved everything.
Let me know if this helped you :)

EDIT: to access this file your device has to be rooted

  • On my N4 (Android 4.4.4), that file doesn't exist--in fact, /data/misc doesn't even exist. The closest matches are /system/etc/wifi/wpa_supplicant.conf and /system/etc/wifi/wpa_supplicant_overlay.conf, neither of which contain any wifi passwords at all. In fact, nothing else in that directory contains passwords, either.
    – Flimzy
    Oct 3, 2014 at 17:11
  • I just checked again. That file is in that precise folder and has every wifi entry I've ever stored. And I checked it on a N4 and on three N5.... O.o
    – Leon
    Oct 4, 2014 at 16:07

I recently answered a QUESTION which had a similar issue.

I'm wondering if it would work for nexus devices as well.


  1. Backup EFS using TWRP/CWM Recovery

  2. Delete ss_data in /efs folder using root file explorer.


I cannot verify this fix, nor can I explain why it might work, but give this a shot

Rename your device

If it works! Awesome! If it doesn't you just wasted 5 minutes of your life following this answer.

  • Do you have a reason to think it would work?
    – Flimzy
    Oct 8, 2014 at 15:22
  • I remember reading this on some other forum back when a friend had the problem. I am unable to find it again, else id have linked it.
    – Aadi Droid
    Oct 8, 2014 at 15:23
  • Well, there doesn't seem to be any unified way to "rename your device." Do you have a suggestion for which way matters?
    – Flimzy
    Oct 8, 2014 at 15:27
  • Just name it anything simple, just to be safe try wihout any special characters? Given how this is magically supposed to solve the issue im sorry this is vague :/ just trying to help
    – Aadi Droid
    Oct 8, 2014 at 15:28
  • My point is, an android device doesn't have "a" name. It has names for different purposes... for bluetooth, in the google device manager, when run as a Wifi AP... and they all have nothing to do with each other. Which sense of "name" are you referring to?
    – Flimzy
    Oct 8, 2014 at 15:30

I have S4 Zoom. Had this problem. Reading your answers i tested with just Root Browser renaming DHCP in /data/misc/ and rebooting and then again passwords needs to put put in but now starts remembering. So you can also just delete that DHCP in /data/misc/. I had this problem already 4 times and this works.

Since i had it already few times maybe Problem then lies in that maybe at some point in reboot or battery down file got corrupted so its not writing or some app changed writing permissions?!?

p.s. for admin. my answer was deleted and now i found this solution and edited and i couldnt undelete so i made new answer.. Thats not helpfull.


Here is the solution which worked for my rooted Nexus 5 (android 5.0.1)

  1. Copy wpa_suppliciant.conf file from /data/misc/wifi/ to your PC
  2. Open with any text editor (I used wordpad) and delete all entries with you problematic wifi name on it.
  3. Choose one of the Wifi in the list which you remember has worked before and change SSID and passkey according to you router. Press SAVE.
  4. Copy/replace this modified file into /data/misc/wifi
  5. Delete DHCP folder in /data/misc/
  6. Reboot your phone.
  7. Voila your phone now connects to your new wifi :)

P.S. Please make a backup of "wpa_suppliciant.conf" file and "DHCP" folder. Just in case

P.P.S. For some people deleting old saved wifi from "saved wifi" did the trick too

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .