1

I'm trying to code something using the calendar-functionality. As there is no support in the emulator, I tried to install the missing apks for CalenderProvider and Calendar. I found a tutorial, but that doesn't work as expected. As I need to code for Froyo the tutorial sounded perfect, but the installation of the files in the linked ZIP-file looks like this:

G:\>"C:\Program Files\Android\platform-tools\adb.exe" install CalendarProvider.apk
367 KB/s (331864 bytes in 0.882s)
        pkg: /data/local/tmp/CalendarProvider.apk
Failure [INSTALL_FAILED_SHARED_USER_INCOMPATIBLE]

G:\>"C:\Program Files\Android\platform-tools\adb.exe" install Calendar.apk
764 KB/s (243369 bytes in 0.311s)
        pkg: /data/local/tmp/Calendar.apk
Success

G:\>

Regarding INSTALL_FAILED_SHARED_USER_INCOMPATIBLE I learned that it has got to do something with the ROM. As I don't have anything else I'm lost here.

Can anyone please help me to circumvent that error message or can provide a working combo for the two apks for Froyo?

  • There is all you need in the emulator... Why there wouldn't be a calendar app ? Beware of the API version you use and the API you run... I never launched a froyo emulator, but there was a calendar in gingerbread. – Matthieu Harlé Jan 27 '14 at 16:20
  • @Shywim All I can say is that there is no calendar app in the emulator. I'm not too familiar with all the details, but that's my situation. – sjngm Jan 27 '14 at 16:30
  • I don't know where you've picked those files from, but as Shywim already pointed out, they must match your platform. If they are taken from GApps, they must be from their Froyo archive in your case. – Izzy Jan 27 '14 at 16:56
  • 1
    @sjngm: Did you set the emulator's target to Google's API? If not, maybe it will solve your problem (just a guess, but since CalendarProvider is in gapps packages...) – Matthieu Harlé Jan 27 '14 at 17:02
  • 1
    @sjngm: I'll put it as an anwser so you can mark your question as solved :) – Matthieu Harlé Jan 31 '14 at 18:35
0

Make sure you downloaded the Google APIs corresponding to your API level in the SDK Manager and that you set your AVD's target on Google APIs. This version of the API is needed for the CalendarProvider (for sync functions with Google I imagine).

enter image description here

  • No, synchronisation is somewhere else. It doesn't work out of the box. There's a blog and a download page. Now I have a problem with read-only file system. – sjngm Jan 31 '14 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.