1

I have a brand new Google Nexus 7 (2013) LTE tablet and first thing I did, was to check if there is any sys update for my device. It was. System reported that 4.3 --> 4.4.2 update is ready to download and install.

However, after updating and hitting button to install, I got Error message and a droid lying icon. After this my tablet has restarted and reverted back to 4.3.

The strangest part is, that I can't repeat (try to install again), because now my tablet claims, that it is up to date, though it still carries factory 4.3 system version on-board.

Is there any known reason for this behavior (not able to upgrade and then to even re-download update)?

Is there any solution to this problem, except:

I am a rather beginner to the Android system, so terms like sideload or update radio/baseband from .84 to .97 says quite nothing to me! :[

EDIT: I read about this (not being able to OTA-upgrate to 4.4.2), but the strange thing is, that most of these sources talks about 59,1 MB upgrade image, while mine was 253,9 MB (five times bigger).

EDIT: I have cleared Google Services Framework cache and data, as suggested by dotVezz in a comment and then I was able to restart download & upgrade to 4.4.2 process. Second attempt ended with success (system upgrated to 4.4.2), so my previous experience seems to be a one-time problem.

  • 1
    Have you tried clearing the data for Google Services Framework? – dotVezz Jan 29 '14 at 22:27
  • As you can see (edited question) clearing data & cache for GSF and restarting upgrade process ended with full success. Please reformulate your above comment as full answer (either another one or better -- reedited current one), so I can accept it and bring you some rep, as your suggestion has actually solved the problem mentioned in my question. – trejder Jan 30 '14 at 9:43
  • I've edited the question. =) – dotVezz Jan 30 '14 at 13:20
2

EDITED 01/30/2014

If you clear the data for Google Services Framework, you can force the OTA update to start again.

There are a few downsides to this, but with a brand new device, you can safely clear the data and perform the OTA update.


Old Answer...

As deailed in this question, you can download the 4.4.2 image directly from Google and install it on your tablet from your computer.

One method is to use Fastboot:

If you're using Windows, you'll need USB Drivers (official link, and easy mode link, Koush's Universal Driver). The file downloaded includes instructions, which basically boil down to...

  1. Reboot into Bootloader/Fastboot mode.
  2. Connect your device to your PC with USB.
  3. Run the appropriate flash-all file for your Desktop OS (Windows .bat files and Bash .sh files are included with the downloaded Android image).

Note: This will also erase all data on your device. Make sure you back up whatever you want to. If I remember correctly, there's a flash-base or similar option that will not erase your data, instead of flash-all.

  • Thanks for your reply, but my question was specific about OTA install -- why (possibly) did it failed and is there any way to restart (perform again) system upgrade, other than manually installing from image. So, your answer is a little bit off-topic though. – trejder Jan 29 '14 at 20:15
  • My mistake! I didn't notice that you specifically mentioned manually using images in your question. You even had a link and everything. – dotVezz Jan 29 '14 at 20:21
  • Edited for correctness. – dotVezz Jan 30 '14 at 13:21
  • I think you can throw away the old answers. Especially, that it is off-topic. I think this is an acceptable behavior at SE. I even read somewhere, that you don't even need to "cross-out" your old answer with <s>. You can (if you wish) just delete everything else and leave just the newest version of your answer. Seen such behavior many times (where only comments suggested, that there was once some other answer! :]) – trejder Jan 30 '14 at 14:11
  • @trejder I appreciate what you're saying, but I personally believe it's best to keep the old answer as well - as long as it's not incorrect, it may still help someone in the future. It may not have been the best answer for you, but someone else may stumble here from a Google search and find it useful. – dotVezz Jan 30 '14 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.