0

This question already has an answer here:

I'm have connectivity issues with the Google Play Store app. I have a non-rooted Note 3 (4.3). The had worked the first few weeks I had the phone in December and then hasn't worked since. I get the same "No connection - Retry" error everytime I access it. I've been have trouble with Google Play Services since I tried disabling it when I realized how much battery life it drained. I've had trouble using Youtube at times but never as persistent and consistent as the Play Store.

I have done the following:

  • Wi-fi/LTE connections, no difference between the two

  • Airplane mode on/off

  • Manual and automatic date/time

  • Updated both Google Play Services and Google Play Store via Android Police

I have basically done everything except a factory reset which seems like the next logical step but it does not fix the problem for everyone. I am trying to figure out if there is anything else I haven't tried that I may be overlooking.

Thank you!

marked as duplicate by ale, Izzy, roxan, Chahk, jlehenbauer Feb 1 '14 at 22:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Seems like it, however none of the suggested methods in the linked thread have helped out @Bench – Zlatty Jan 30 '14 at 21:58
  • 1
    You NEED Google Play Services enabled. Re-enable it. If battery drain is an issue it is almost certainly down to location history, location requests and location reporting. Turn them off in your Google settings, but make sure the actual Play Services are enabled. If you've done that, the clear the market Cache and Data and reboot the device and log back in to the Play Store again. Here is some info on the battery drain issue if you want more depth: forum.xda-developers.com/nexus-4/help/… – RossC Jan 31 '14 at 9:52
  • I had a similar issue and found it was due to having previously installed Adblock-Plus. It requires you set up a localhost proxy in your WiFi connections. When I removed Adblock-Plus I forgot to undo the proxy settings. When I removed the proxy the connection worked fine. – Steve Lorimer Aug 26 '14 at 0:07
2

@RossC I had Google Play Services enable but I went to check my disabled list and Google Play Services Framework was disabled! You helped my find the answer! Thank you, sir, for the help and the link to help with battery drain!

Not the answer you're looking for? Browse other questions tagged or ask your own question.