5

I bought a Nexus 7 2012 grouper. I used wug's nexus 7 rootkit tool for windows on WinXp. The drivers took a bit of tinkering but eventually I got the Raw drivers configured. Everything was going along just fine, unlocked, rooted, flashed recovery happy day! Downloaded and flashed Paranoid Android it booted up.

Paranoid was optimizing my apps (it had a couple hundread to do) so i figured I was past the critical part so I closed the case and put it down to do other things...

Aparently this was a bad idea. It boot looped when I turned ir back on. Tried to optimize apps again for a secons then went back to the boot animation. I turned it off and back on and it never went to app optimization again just boot animation. Now it just fails to boot and I cant get past the bootloader.

Recovery mode wont load but bootloader will.

I tried to flash recovery but adb says it cannot find the device. I had this problem before until I got the right drivers installed and updated and the kicker that made it all work was my pc's signature popping up on my nexus and I said ok to give access. Because im stuck in bootloader mode it doesnt give me the option to allow the pc access, this seems like a problem.

I tried to use wugs tools for softbricked devices, flash stock with wugs but I get

Writeing bootloader FAILED Invalid State

And the .bat hangs and cannot be closed without a reboot.

I also tried from linux where I have the android dev setup. Before I started this process it allowed me to access the nexus file system pretty reliably. Now linux does not notice that anything is plugged in and adb says Device Not Found.

So this is where I am at. Please and thank you for your help.

  • If you can get the bootloader, you can use fastboot to flash a new Recovery, and even do a factory reset. But just to confirm, what happens if you plug it in, then type sudo fastboot devices from Linux? – dotVezz Jan 30 '14 at 20:00
  • Oo! It gives me a big long number string and fastboot thats the nexus right?! – Himalaya Jan 31 '14 at 0:41
  • I've posted an answer with a few of your options. Also, if I had to guess, I'd guess that you installed ParanoidAndroid from stock, without doing a factory reset - and that was probably what was wrong. – dotVezz Jan 31 '14 at 1:27
4

Since you do have working fastboot access, you have a few options from there:

You can...

  • Get a custom recovery like TWRP. Then run fastboot flash recovery /path/to/twrp.img.
    • With TWRP, you can to try to reinstall ROMS, do factory resets, and make backups of your current system (Which may be a good idea, even if it's bricked).
  • Do a factory reset with fastboot format data and fastboot format cache.
  • Try to install stock Android (keeping data) from the Factory Images by running included flash-base.sh, included in the image download.
  • If all else fails, you can unbrick it by running the flash-all.sh - which will essentially reset it to a like-new state, with the stock OS and no data.

If you wind up doing a factory reset after all, you can use Titanium Backup to extract the apps and settings from the TWRP backups.

  • Ok so i flashed recovery and i now can get into recovery mode. First thing that happens is Iit asks me for a password (what password?). So it lets me cancel out of the password screen and gives me options. At this point I just want the quickest way to functional tablet. So I tried a few things: I tried backing up it says "unable to mount /system unable to mount /cashe. – Himalaya Feb 1 '14 at 3:31
  • I also tried formating data but it said "formating not supported in partitions of type ' '. I also tried flashall but apparently ive got my syntax wrong because it talks about -p product which apparently isnt "nexus 7" so ill go read some guides and see whatI can do. Also I have an app backup made with wugs will I be able to restore that later? – Himalaya Feb 1 '14 at 3:50
3

Ok Solved! We have Operation! Here is what happened.

Fastboot format data failed "cannot format partition type ' '

Please Enter Password: Error Popped up in TWRP when I had never set one and when I tried to do anything it could never mount /system or /cache or anything I did fastboot flash recovery Clockwork recovery zip and from there

I got the error 'cannot read sideload'. Luckily the answer to that was a Google search away with the fix of putting the file in the same dir as adb.

So by using Clockwork Recovery "Install from Sideload" option andadb sideload rom.zip I was able to install a custom rom and boot into it! woooohooo UNbricked!

Thanks!

  • Crazy weird issues you had, but good job getting it working. Good display of ingenuity. – dotVezz Feb 1 '14 at 21:03
  • Yeah im new to android but not computers. I swear sometimes they are just testing our courage. I couldnt have done it without you, thank you very much! – Himalaya Feb 2 '14 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.