0

After switching to a new ROM I restored Google Now using Titanium backup but however I no longer have hotword detection enabled neither do I have the option to enable it (It is simply missing)!

It used to say Search, or say "OK Google" but now it only says Search

However, speech recognition in general works fine!

Other relevant information:

  • Using Samsung Galaxy SII
  • Using Vivek ROM but experienced same problem on CyanogenMod

1 Answer 1

1

Solved it!

I realised that I had set Language to 'English(UK)' (under 'voice' settings of the Google Now app) and apparently hotword detection currently works only with English(US) (In my case, the offline voice recognition package I had installed was 'English(US)' , but language was English(UK) )!

Solution:

So a simple switching of 'Language' to English(US) will do the trick!

It is a little funny, who would have guessed English(US) and English(UK) are considered completely different languages!

By the way:

I tried downloading and installing English(UK) as my offline voice recognition language and then switching the Language as well to English(UK) BUT it didn't work, hotword detection stopped working again. This means Hotword detection only works with English(US) irrespective of whether you have other offline voice recognition packages installed as well!

2
  • You don't need to put edits in an "edit" section. Your answer would be most useful if you just make the correction; as it stands, the answer tells people the wrong thing, and then says it's wrong.
    – Dan Hulme
    Jan 31, 2014 at 9:58
  • Will keep in mind...(fixed solution)
    – reubenjohn
    Jan 31, 2014 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .