2

I have tried using the command adb tcpip 5555 to be able to connect wirelessly to my test devices. It's working fine for devices running Android 4.0+, but every 2.x device (like the Galaxy Ace, running 2.3) I have tried gives the same result:

$ adb connect 10.26.5.215
unable to connect to 10.26.5.215:5555

I haven't been able to find anything online that says this feature only works on Android 4 - is this the case?

Will it be possible to connect ADB over TCP/IP on the 2.x devices if I root them?

N.B. I do not want to install custom kernels or ROMs, I want them to be in as similar a state to stock devices as possible.

2

Yes, you can, but not through the same steps as on Android 4.0+ devices.

Once your phone is rooted, run the following commands to change ADB to TCP mode and restart the adb daemon (note that you can pick the port number, I am sticking with the default of 5555):

$ su
# setprop service.adb.tcp.port 5555
# stop adbd
# start adbd

You can run the first three commands over adb shell, but will need to start adbd again from a terminal on the phone itself (I had strange problems when doing otherwise). You can now disconnect the USB cable if you want to, and you can connect to the phone over TCP/IP:

mycomputer$ adb connect 10.26.5.215
connected to 10.26.5.228:5555

(if you are using a non-default port you will need to specify it: adb connect 10.26.5.215:5556)

I have tested this on a Samsung Galaxy Ace (GT-S5830i) and a Galaxy S (GT-I9000), and installing APKs and running instrumentation tests are working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.