5

I tried connecting it nexus 5 to my pc via USB. Although it shows as connected in my external devices and also shows up in My Computer, but when I try to open it and don't files to my phone, it just shows a plain, blank screen with the green placing had on top.

  • Did you unlock the screen? This also happened to me on my Nexus 4 when I didn't unlock the screen. – sancowinx Feb 1 '14 at 7:07
  • I did. But it's the same. Shows connected in my computer. But when I click the folder, it just keeps on loading and nothing show up except a blank screen/empty folder. – Vj5891 Feb 3 '14 at 6:28
  • @Vj5891 check this vid > youtube.com/watch?v=t6dtNLJJF3o. Also, I suggest you should download and install the Google USB Driver. developer.android.com/sdk/win-usb.html – sancowinx Feb 3 '14 at 6:59
6
  1. Enable USB debugging: Go to phone settings -> About -> Tap build number repeatedly until developer menu is enabled. Go there and tick USB debugging.

  2. On your PC, go to your device manager (You can find it in Control Panel, System) when the Phone is plugged in and set to MTP. Locate the phone, (it might come up as "Android Phone" if so open the tree a level. On my computer it says "Google Nexus ADB Interface" but it might be different on yours depending on how you've got things configured) right click on it and chose "properties" from the fly out menu.

  3. Go to the Driver tab

  4. Click Update Driver. . .

  5. Click Browse my Computer for driver software

  6. Click Let my pick from a list of devices on my computer

  7. select USB Composite Device

  8. Close the driver assistant

Your Nexus 5 should now appear as an MTP device on your computer.

| improve this answer | |
  • Brilliant. For me it originally showed as "Acer ADB Interface". From the list of devices on my computer, I could choose "MTP USB Device". After this switch, I saw it appear as "Nexus 5" on the driver list, and it worked. This was on Windows 8.1. – basicdays Oct 26 '14 at 7:35
  • I can confirm this also works for the Nexus 5X with Android 7.1 and Windows 7. – mhsmith Oct 24 '19 at 12:57
2

Connect your mobile, slide down from the top of your mobile to find USB FOR CHARGING, select MTP.

| improve this answer | |
  • 1
    Can you add info as to how to make MTP the default option (in your answer)? – Tamoghna Chowdhury Nov 5 '15 at 7:48
1

I had similar problem at first. Try this:

  1. Uninstall the driver (ADB Driver) manually from Device Manager.

  2. Unplug the device.

  3. Plug it so that windows automatically tries to find it.

Must work.

| improve this answer | |
0

I've had a similar problem for some months after over a year of normal operation but with a Nexus 4 Android (now Lollipop) phone and an Acer laptop running Windows 7. The Nexus would not show up in Windows Explorer in MTP mode, only PTP mode. That is ok for moving photos over to my laptop but not for making a backup of Android files, or data such as an exported Contacts list. On revisiting this problem and finding this page I did the following:

  1. Plug Nexus 4 into laptop (laptop acknowledges the connexion with its sound-effect)
  2. Go to Control Panel > Devices and Printers and click on Nexus
  3. Select Hardware, which shows Acer ADB Interface -- this seems to be what was wrong
  4. Go to Control Panel > Drivers, select Acer ADB Interface and delete it
  5. Unplug Nexus 4 and plug it in again, Windows goes off to find a driver for it
  6. Windows then installs a Nexus 4 driver, not the Acer ADB driver, and all is well.

Strangely, the Nexus driver has an earlier date and a lower version number than the Acer ADB driver had, suggesting it had somehow got upgraded. Perhaps I needed the Acer ADB driver for something, but I'll worry about that when I find out what.

| improve this answer | |
0

Sometimes the driver update alone does not work. For me, I also had to use a better USB cable. The cheap ones you can buy online are a lower quality. If I use the one that came with the phone, it doesn't do that disconnecting thing the whole time.

| improve this answer | |
0
  1. Unplug USB cable from your PC.
  2. Go to 'Settings' > 'Storage'.
  3. In options, click 'USB computer connection'
  4. Now check on 'Camera (PTP)'
  5. Connect your device to PC.
  6. After connecting, if drivers are installed successfully, unplug device, switch back to MTP mode and connect to PC.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.